C - Monkey and Banana (dp)

A group of researchers are designing an experiment to test the IQ of a monkey. They will hang a banana at the roof of a building, and at the mean time, provide the monkey with some blocks. If the monkey is clever enough, it shall be able to reach the banana by placing one block on the top another to build a tower and climb up to get its favorite food. 

The researchers have n types of blocks, and an unlimited supply of blocks of each type. Each type-i block was a rectangular solid with linear dimensions (xi, yi, zi). A block could be reoriented so that any two of its three dimensions determined the dimensions of the base and the other dimension was the height. 

They want to make sure that the tallest tower possible by stacking blocks can reach the roof. The problem is that, in building a tower, one block could only be placed on top of another block as long as the two base dimensions of the upper block were both strictly smaller than the corresponding base dimensions of the lower block because there has to be some space for the monkey to step on. This meant, for example, that blocks oriented to have equal-sized bases couldn't be stacked. 

Your job is to write a program that determines the height of the tallest tower the monkey can build with a given set of blocks. 

Input

The input file will contain one or more test cases. The first line of each test case contains an integer n, 
representing the number of different blocks in the following data set. The maximum value for n is 30. 
Each of the next n lines contains three integers representing the values xi, yi and zi. 
Input is terminated by a value of zero (0) for n. 

Output

For each test case, print one line containing the case number (they are numbered sequentially starting from 1) and the height of the tallest possible tower in the format "Case case: maximum height = height". 

Sample Input

1
10 20 30
2
6 8 10
5 5 5
7
1 1 1
2 2 2
3 3 3
4 4 4
5 5 5
6 6 6
7 7 7
5
31 41 59
26 53 58
97 93 23
84 62 64
33 83 27
0

Sample Output

Case 1: maximum height = 40
Case 2: maximum height = 21
Case 3: maximum height = 28
Case 4: maximum height = 342

一道经典的DP题目,类似于求最长递增子序列吧。

题意:

一堆科学家研究猩猩的智商,给他M种长方体,每种N个。

然后,将一个香蕉挂在屋顶,让猩猩通过 叠长方体来够到香蕉。

 

现在给你M种长方体,计算,最高能堆多高。

要求位于上面的长方体的长要大于(注意不是大于等于)下面长方体的长,上面长方体的宽大于下面长方体的宽。

 

解题:

一个长方体,可以有6种不同的摆法。

因为数据中 长方体种类最多30种,也就是说数组最大可以开到 30*6=180 完全可以

 

然后用dp[i]来存,到第i个木块,最高可以累多高。

当然,长方体先要以长度排序,长度相同则宽度小的在上。

 

(⊙v⊙)嗯,OK~
代码:


//Full of love and hope for life

#include <iostream>
#include <algorithm>
#include <stdio.h>
#include <string.h>
#include <math.h>
#include <queue>
#define inf 0x3f3f3f3f
//https://paste.ubuntu.com/

using namespace std;

typedef long long ll;

struct node{
   int x,y,z;
};

node n[200];
int dp[200];

bool cmp(node a,node b){
    if(a.x==b.x){
        return a.y<b.y;
    }
    return a.x<b.x;
}

int main(){
    int a,t,k=0;
    int i,j;
    while(cin >> a){
        if(a==0){
            break;
        } 
        k++;
        memset(dp,0,sizeof(dp));
        t=0;
        int x,y,z;
        for(i=1;i<=a;i++){
            cin >> x >> y >> z;
            n[++t].x=x;n[t].y=y;n[t].z=z;
            n[++t].x=x;n[t].y=z;n[t].z=y;
            n[++t].x=y;n[t].y=x;n[t].z=z;
            n[++t].x=y;n[t].y=z;n[t].z=x;
            n[++t].x=z;n[t].y=y;n[t].z=x;
            n[++t].x=z;n[t].y=x;n[t].z=y;//将所有情况都存起来
        }
        sort(n+1,n+t+1,cmp);//排个序
        dp[1]=n[1].z;
        int mm=0;
        for(i=2;i<=t;i++){
               int ma=0;
           for(j=1;j<i;j++){
               if(n[j].y<n[i].y&&n[j].x<n[i].x){//上一层两个边都要小于下一层的两个边
                   ma=max(ma,dp[j]);
               }
           }
           dp[i]=n[i].z+ma;
           mm=max(mm,dp[i]);
       }
       cout << "Case " << k << ": " << "maximum height = ";
       cout << mm << endl;
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

ZZ --瑞 hopeACMer

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值