C - Monkey and Banana HDU - 1069

[kuangbin带你飞]专题十二 基础DP1;

网址:https://cn.vjudge.net/contest/68966#problem/C


                    C - Monkey and Banana

  HDU - 1069 

A group of researchers are designing an experiment to test the IQ of a monkey. They will hang a banana at the roof of a building, and at the mean time, provide the monkey with some blocks. If the monkey is clever enough, it shall be able to reach the banana by placing one block on the top another to build a tower and climb up to get its favorite food. 

The researchers have n types of blocks, and an unlimited supply of blocks of each type. Each type-i block was a rectangular solid with linear dimensions (xi, yi, zi). A block could be reoriented so that any two of its three dimensions determined the dimensions of the base and the other dimension was the height. 

They want to make sure that the tallest tower possible by stacking blocks can reach the roof. The problem is that, in building a tower, one block could only be placed on top of another block as long as the two base dimensions of the upper block were both strictly smaller than the corresponding base dimensions of the lower block because there has to be some space for the monkey to step on. This meant, for example, that blocks oriented to have equal-sized bases couldn't be stacked. 

Your job is to write a program that determines the height of the tallest tower the monkey can build with a given set of blocks. 
Input
The input file will contain one or more test cases. The first line of each test case contains an integer n, 
representing the number of different blocks in the following data set. The maximum value for n is 30. 
Each of the next n lines contains three integers representing the values xi, yi and zi. 
Input is terminated by a value of zero (0) for n. 
Output
For each test case, print one line containing the case number (they are numbered sequentially starting from 1) and the height of the tallest possible tower in the format "Case case: maximum height = height". 
Sample Input
1
10 20 30
2
6 8 10
5 5 5
7
1 1 1
2 2 2
3 3 3
4 4 4
5 5 5
6 6 6
7 7 7
5
31 41 59
26 53 58
97 93 23
84 62 64
33 83 27
0
Sample Output
Case 1: maximum height = 40
Case 2: maximum height = 21
Case 3: maximum height = 28
Case 4: maximum height = 342


题意:给你n个长方体以及每个的长宽高,这些长方体的数量无限且可以任意旋转。长方体可以叠放在长和宽都比它大的长方体上(不能都相等),问最高能叠多高。

思路:把这题看作类似于LIS的题目,我们将每个长方体的6个状态都存起来(一共不超过180种)——以各边长作高且长宽可互换,所以6种。接下来进行排序使长大的放前面,如果相同则宽大的放前面,那么这个问题就变成了对于一段序列,问其满足条件的权值最大的子序列。对比LIS,这里的高就是权值,也就是LIS中的长度,条件是长宽要小于它前面那个,也就是LIS中的数值要小于前面那个。那么就可以写出一个1D/1D的dp方程。

代码:

#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
using namespace std;

struct Point{
   int x,y,h;
}point[200];

int cmp(Point a,Point b)
{
    if(a.x != b.x){
        return a.x > b.x;
    }
    else{
        return a.y > b.y;
    }
}

int main()
{
    int t;
    int Case = 1;
    while(scanf("%d",&t) != EOF){
        int a,b,c;
        if(t == 0) return 0;
        for(int i = 0;i < t;i++){
            scanf("%d%d%d",&a,&b,&c);
            point[6*i].x = a,point[6*i].y = b,point[6*i].h = c;
            point[6*i+1].x = b,point[6*i+1].y = c,point[6*i+1].h = a;
            point[6*i+2].x = c,point[6*i+2].y = a,point[6*i+2].h = b;
            point[6*i+3].x = b,point[6*i+3].y = a,point[6*i+3].h = c;
            point[6*i+4].x = c,point[6*i+4].y = b,point[6*i+4].h = a;
            point[6*i+5].x = a,point[6*i+5].y = c,point[6*i+5].h = b;
        }
        sort(point,point+6*t,cmp);
        int dp[200];
        for(int i = 0;i < 6*t;i++){
            dp[i] = point[i].h;
            for(int j = 0;j < i;j++){
                if(point[i].x < point[j].x && point[i].y < point[j].y){
                    dp[i] = max(dp[i],dp[j]+point[i].h);
                }
            }
        }
        int maxn = 0;
        for(int i = 0;i < 6*t;i++){
            if(maxn < dp[i]){
                maxn = dp[i];
            }
        }
        printf("Case %d: maximum height = %d\n",Case++,maxn);
    }
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值