C练习——福尔摩斯的约会(A1061/B1014)

Sherlock Holmes received a note with some strange strings: Let's date! 3485djDkxh4hhGE 2984akDfkkkkggEdsb s&hgsfdk d&Hyscvnm. It took him only a minute to figure out that those strange strings are actually referring to the coded time Thursday 14:04 -- since the first common capital English letter (case sensitive) shared by the first two strings is the 4th capital letter D, representing the 4th day in a week; the second common character is the 5th capital letter E, representing the 14th hour (hence the hours from 0 to 23 in a day are represented by the numbers from 0 to 9 and the capital letters from A to N, respectively); and the English letter shared by the last two strings is s at the 4th position, representing the 4th minute. Now given two pairs of strings, you are supposed to help Sherlock decode the dating time.

Input Specification:

Each input file contains one test case. Each case gives 4 non-empty strings of no more than 60 characters without white space in 4 lines.

Output Specification:

For each test case, print the decoded time in one line, in the format DAY HH:MM, where DAY is a 3-character abbreviation for the days in a week -- that is, MON for Monday, TUE for Tuesday, WED for Wednesday, THU for Thursday, FRI for Friday, SAT for Saturday, and SUN for Sunday. It is guaranteed that the result is unique for each case.

Sample Input:

3485djDkxh4hhGE 
2984akDfkkkkggEdsb 
s&hgsfdk 
d&Hyscvnm

Sample Output:

THU 14:04

思路

DAY:前两个字符串第一对相同位置的大写字母(A-G)

HH:DAY位置之后第一对相同位置的大写字母(A_N)或数字

MM:后两个字符串第一对相同位置的英文字母(A-Z、a-z)

代码

#include <stdio.h>
#include <string.h>

int main()
{
    char a[60],b[60],c[60],d[60];
    char w[7][4]={"MON","TUE","WED","THU","FRI","SAT","SUN"};   //字符串需留'\0'位置,所以为3+1=4
    while(scanf("%s%s%s%s",a,b,c,d)!=EOF){
        int count=0;                                           //计数器,为0时计算星期,为1时计算小时
        for(int i=0;i<strlen(a)&&i<strlen(b);i++){
            if(a[i]==b[i]&&count==0&&a[i]>='A'&&a[i]<='G'){    //必须严格A-G,否则会超出w的索引范围
                printf("%s ",w[a[i]-'A']);                      //a[i]-'A'为据MON的差距
                count++;
                continue;
            }
            if(a[i]==b[i]&&count==1){
                if(a[i]>='0'&&a[i]<='9'){           //注意是与字符'0'-'9'比较
                    printf("%02d:",a[i]-'0');       //需输出整数,否则报错
                    break;                          //求出小时后必须break,即使之后存在满足条件的值也不应输出,否则会报错
                }
                else if(a[i]>='A'&&a[i]<='N'){     //必须严格A-N,否则输出会大于23
                    printf("%d:",a[i]-'A'+10);      //10+据'A'的差
                    break;                         //求出小时后必须break,即使之后存在满足条件的值也不应输出,否则会报错
                }
            }
        }
        for(int i=0;i<strlen(c)&&i<strlen(d);i++){
            if(c[i]==d[i]&&((c[i]>='A'&&c[i]<='Z')||(c[i]>='a'&&c[i]<='z'))){   //必须为字母
                printf("%02d",i);
                break;                             //求出分钟后必须break,即使之后存在满足条件的值也不应输出,否则会报错
            }
        }
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值