【PAT(甲级)】1061 Dating(详细的易错点)

Sherlock Holmes received a note with some strange strings: Let's date! 3485djDkxh4hhGE 2984akDfkkkkggEdsb s&hgsfdk d&Hyscvnm. It took him only a minute to figure out that those strange strings are actually referring to the coded time Thursday 14:04 -- since the first common capital English letter (case sensitive) shared by the first two strings is the 4th capital letter D, representing the 4th day in a week; the second common character is the 5th capital letter E, representing the 14th hour (hence the hours from 0 to 23 in a day are represented by the numbers from 0 to 9 and the capital letters from A to N, respectively); and the English letter shared by the last two strings is s at the 4th position, representing the 4th minute. Now given two pairs of strings, you are supposed to help Sherlock decode the dating time.

Input Specification:

Each input file contains one test case. Each case gives 4 non-empty strings of no more than 60 characters without white space in 4 lines.

Output Specification:

For each test case, print the decoded time in one line, in the format DAY HH:MM, where DAY is a 3-character abbreviation for the days in a week -- that is, MON for Monday, TUE for Tuesday, WED for Wednesday, THU for Thursday, FRI for Friday, SAT for Saturday, and SUN for Sunday. It is guaranteed that the result is unique for each case.

Sample Input:

3485djDkxh4hhGE 
2984akDfkkkkggEdsb 
s&hgsfdk 
d&Hyscvnm

Sample Output:

THU 14:04

解题思路:

题目就是给出4个字符串,让我们找到相同的英文字符,再进行相应的运算,求出时间就可以了。

用数组来存储星期一到星期日会方便一点。

易错点:

1. 第一次相同的字母必须在'A'-'G'之间;

2. 第二次相同的必须在'A'-'N'或者'0'-'9'之间;

3. 确定分钟的相同字符一定要是英文字母即'A'-'Z'或者'a'-'z';

4. 一定要确保你星期一到星期天的英文字母正确!!!!

代码:

#include<bits/stdc++.h>
using namespace std;
int main(){
	string a,b,c,d;
	cin>>a>>b>>c>>d;
	char index1 = NULL;
	char index2;
	string hh;
	string ss;
    int flag = 0;
	string Day[7]={"SUN","MON","TUE","WED","THU","FRI","SAT"};
	for(int i=0;i<a.size();i++){
		if(a[i]==b[i]&&flag &&(a[i]>='A'&&a[i]<='N'||a[i]>='0'&&a[i]<='9')){
			index2 = a[i];
            break;
		}
        if(index1 == NULL && a[i]==b[i] && a[i]>='A'&&a[i]<='G'){
			index1 = a[i];
            flag = 1;
		}
	}
	if(index2>='0'&&index2<='9'){
		hh+=to_string(index2-'0');
	}else{
		hh+=to_string(10+index2-'A');
	}

	for(int i=0;i<c.size();i++){
		if(c[i]==d[i] && (c[i]>='A'&&c[i]<='Z'||c[i]>='a'&&c[i]<='z')) {
            ss = to_string(i);
            break;
        }
	}
	
	if(ss.size()==1) ss = "0"+ss;
	if(hh.size()==1) hh = "0"+hh;
	cout<<Day[(index1-'A'+1)%7]<<" "<<hh<<":"<<ss;
	return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值