题目描述
输入一个十进制整数n,转换成2、3、7、8进制输出
要求程序定义一个dToK()函数,功能是将十进制数转化为k进制整数,其余功能在main()函数中实现。
void dToK(int n, int k, char str[])
{
//将n转化为k进制数,存入str
}
输入
输入一个int范围内的正整数n
输出
输出为4行,分别是n对应的2、3、7、8进制数
样例输入
13
样例输出
1101
111
16
15
来源:
题解:
#include<iostream>
#include<string.h>
#include<algorithm>
#include <math.h>
long long a,b,c,d[99999];
char d1[99999];
using namespace std;
void dToK(int n,int k,char str[])
{
int i=0,temp,o=0;
temp=n;
while(temp)//将输入的数的每一位都用k进制表示并存入字符数组中
{
i=temp%k;
str[o]=i+'0';
o++;
temp=temp/k;
}
for(int p=o-1;p>=0;p--)//输出处理的字符数组
{
cout<<str[p];
}
cout<<endl;
}
int main()
{
int a,b;
char str[99999];
cin>>a;
dToK(a,2,str);//调用
dToK(a,3,str);
dToK(a,7,str);
dToK(a,8,str);
}