poj2653(计算几何)

Stan has n sticks of various length. He throws them one at a time on the floor in a random way. After finishing throwing, Stan tries to find the top sticks, that is these sticks such that there is no stick on top of them. Stan has noticed that the last thrown stick is always on top but he wants to know all the sticks that are on top. Stan sticks are very, very thin such that their thickness can be neglected. 

Input
Input consists of a number of cases. The data for each case start with 1 <= n <= 100000, the number of sticks for this case. The following n lines contain four numbers each, these numbers are the planar coordinates of the endpoints of one stick. The sticks are listed in the order in which Stan has thrown them. You may assume that there are no more than 1000 top sticks. The input is ended by the case with n=0. This case should not be processed.
Output
For each input case, print one line of output listing the top sticks in the format given in the sample. The top sticks should be listed in order in which they were thrown.

The picture to the right below illustrates the first case from input. 

Sample Input

5
1 1 4 2
2 3 3 1
1 -2.0 8 4
1 4 8 2
3 3 6 -2.0
3
0 0 1 1
1 0 2 1
2 0 3 1
0

Sample Output

Top sticks: 2, 4, 5.
Top sticks: 1, 2, 3.

Hint
Huge input,scanf is recommended.

挨个输入木棍,从第一个开始判断,第一个是否与后面n-1个相交,相交则第一个不是最上面的棍。
再利用模板,就出来了。
代码:

#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
struct Dian
{
    double x,y;
};
struct Line
{
    Dian a,b;
}line[100001];
bool vis[100001];
 
double Min(double a,double b)
{
    return a>b?b:a;
}
double Max(double a,double b)
{
    return a>b?a:b;
}
 
double chaji(Dian p1,Dian p2,Dian p0)
{
    return (p1.x-p0.x)*(p2.y-p0.y)-(p1.y-p0.y)*(p2.x-p0.x);
}
 
bool across(Line m,Line n)
{
    if( Min(m.a.x,m.b.x)<=Max(n.a.x,n.b.x) &&
       Min(n.a.x,n.b.x)<=Max(m.a.x,m.b.x) &&
       Min(m.a.y,m.b.y)<=Max(n.a.y,n.b.y) &&
       Min(n.a.y,n.b.y)<=Max(m.a.y,m.b.y) &&
       chaji(m.a,n.b,n.a)*chaji(m.b,n.b,n.a)<0 &&
       chaji(n.a,m.b,m.a)*chaji(n.b,m.b,m.a)<0)
        return 1;
    else    return 0;
}
 
 
 
int main()
{
    int n,i,j;
    while(scanf("%d",&n)!=EOF)
    {
        if(!n)  break;
        for(i=0;i<n;++i)
            scanf("%lf%lf%lf%lf",&line[i].a.x,&line[i].a.y,&line[i].b.x,&line[i].b.y);
        memset(vis,0,sizeof(vis));
 
        for(i=0;i<n;++i)
        {
            if(vis[i])  continue;
            for(j=i+1;j<n;++j)
            {
                if(across(line[i],line[j]))
                {
                    vis[i]=1;
                    break;
                }
            }
        }
 
        bool flag=0;
        printf("Top sticks:");
        for(i=0;i<n;++i)
        {
            if(!vis[i])
            {
                if(!flag)   {printf(" %d",i+1);flag=1;}
                else    printf(", %d",i+1);
            }
        }
        printf(".\n");
    }
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值