hdu3449

FJ is going to do some shopping, and before that, he needs some boxes to carry the different kinds of stuff he is going to buy. Each box is assigned to carry some specific kinds of stuff (that is to say, if he is going to buy one of these stuff, he has to buy the box beforehand). Each kind of stuff has its own value. Now FJ only has an amount of W dollars for shopping, he intends to get the highest value with the money.
The first line will contain two integers, n (the number of boxes 1 <= n <= 50), w (the amount of money FJ has, 1 <= w <= 100000) Then n lines follow. Each line contains the following number pi (the price of the ith box 1<=pi<=1000), mi (1<=mi<=10 the number goods ith box can carry), and mi pairs of numbers, the price cj (1<=cj<=100), the value vj(1<=vj<=1000000)
For each test case, output the maximum value FJ can get
Sample Input
3 800
300 2 30 50 25 80
600 1 50 130
400 3 40 70 30 40 35 60

Sample Output

210
题意:
给你一些物品,每个物品有自己的价值和花费,每个物品都对应一个箱子,每个箱子有价钱,买这个物品必须买相应的箱子,给你一个价钱,问最多可以获得多少价值
<提示:多个物品可能同时对应着一个箱子>。

思路:

有依赖的背包,每个箱子是“主件” 每个箱子所对应的物品是他的“附件”,有依赖的背包的过程就是把没一组主件和附件的集合中附件跑一遍01背包,然后把主件强加到跑完后的数组里,然后再在虽有的集合中选择最优的dp[i]的值,这样更新到最后就行了,这样更新 跑附件之间的01背包后强加主件是对应着题意的必须有盒子,而集合和集合之间的更新是对应着 可以再多可集合中选择最优。
代码:

   #include<cstdio>
#include<cstring>
#include<iostream>
#include<queue>
#include<vector>
#include<algorithm>
#include<string>
#include<cmath>
#include<set>
#include<map>
#include<vector>
using namespace std;
int p[105],dp[55][100005];
struct node{
	int v,w;
};
vector<node> g[105];
int main()
{
	int n,m,i,j,k,x,y,w;	
	while(scnaf("%d%d",&n,&w)!='EOF')
	{
		memset(dp,0,sizeof(dp));
		for(int i=1;i<=n;i++)
		{
			g[i].clear();
		}
		for(int i=1;i<=n;i++)
		{
			scanf("%d",&p[i]);
			scanf("%d",&m);
			for(int i=1;i<=m;i++)
			{
				scanf("%d%d",&x,&y);
				g[i].push_back((node){x,y});
			}
		}
		memset(dp,0,sizeof(dp));
		for(int i=1;i<=n;i++)
		{
			for(int j=0;j<p[i];j++)
			{
				dp[i][j]=-1;
			}
			for(int j=p[i];j<=w;j++)
			{
				dp[i][j]=dp[i-1][j-p[i]];
			}
			for(int j=0;j<g[i].size();j++)
			{
				for(int k=w;k>=g[i][j].v;k--)
				{
					if(dp[i][j]!=-1)
					{
						 dp[i][k]=max(dp[i][k],dp[i][k-G[i][j].v]+G[i][j].w);
					}
				}
			}
		 for(j=0;j<=w;j++)                   
            dp[i][j]=max(dp[i][j],dp[i-1][j]);	
		}
		 printf("%d\n",dp[n][w]);
	}
	return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值