HDU 3449:Consumer

Consumer

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/65536 K (Java/Others)
Total Submission(s): 2360    Accepted Submission(s): 1260


Problem Description
FJ is going to do some shopping, and before that, he needs some boxes to carry the different kinds of stuff he is going to buy. Each box is assigned to carry some specific kinds of stuff (that is to say, if he is going to buy one of these stuff, he has to buy the box beforehand). Each kind of stuff has its own value. Now FJ only has an amount of W dollars for shopping, he intends to get the highest value with the money.
 

Input
The first line will contain two integers, n (the number of boxes 1 <= n <= 50), w (the amount of money FJ has, 1 <= w <= 100000) Then n lines follow. Each line contains the following number pi (the price of the ith box 1<=pi<=1000), mi (1<=mi<=10 the number goods ith box can carry), and mi pairs of numbers, the price cj (1<=cj<=100), the value vj(1<=vj<=1000000)
 

Output
For each test case, output the maximum value FJ can get
 

Sample Input
  
  
3 800 300 2 30 50 25 80 600 1 50 130 400 3 40 70 30 40 35 60
 

Sample Output
  
  
210
 

Source


题意:

有N个箱子,每个箱子需要花费Ai的代价

箱子里面有K个物品,K个物品你可以选择买任意个,但每个物品只能买一个,每个物品有相应的花费和价值

你又M的大洋,最后问最多能得到多少价值物品。

解题思路:

先对每组选择里的所有物品进行0-1背包处理,但背包容量为(总容量-盒子容量);然后跟上一组的状态比较来决定这一组选择

 是选还是不选,取其中的较大值。



源代码:


#include<cstdio>
#include<cstring>
const int M=100010;
int dp[55][M];
int max(int a,int b){return a>b?a:b;}
int main()
{
    int n,sum,p,m,w,v;
    while(scanf("%d%d",&n,&sum)!=EOF)
    {
        memset(dp,0,sizeof(dp));
        for(int i=1;i<=n;i++)
        {
            memcpy(dp[0],dp[1],sizeof(dp[1]));//继承前面的
            scanf("%d%d",&p,&m);
            for(int j=1;j<=m;j++)
            {
                scanf("%d%d",&w,&v);
                for(int k=sum-p;k>=w;k--)
                    dp[0][k]=max(dp[0][k],dp[0][k-w]+v);//先将附件进行1次01背包
            }
            for(int j=p;j<=sum;j++))//更新能更新的
                dp[1][j]=max(dp[1][j],dp[0][j-p]); //分组背包
        }
        printf("%d\n",dp[1][sum]);
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值