Piotr‘s Ants

Piotr likes playing with ants. He has n of them on a horizontal pole L cm long. Each ant is facing
either left or right and walks at a constant speed of 1 cm/s. When two ants bump into each other, they
both turn around (instantaneously) and start walking in opposite directions. Piotr knows where each
of the ants starts and which direction it is facing and wants to calculate where the ants will end up T
seconds from now.
Input
The first line of input gives the number of cases, N. N test cases follow. Each one starts with a line
containing 3 integers: L , T and n (0 ≤ n ≤ 10000). The next n lines give the locations of the n ants
(measured in cm from the left end of the pole) and the direction they are facing (L or R).
Output
For each test case, output one line containing ‘Case #x:’ followed by n lines describing the locations
and directions of the n ants in the same format and order as in the input. If two or more ants are at
the same location, print ‘Turning’ instead of ‘L’ or ‘R’ for their direction. If an ant falls off the pole
before T seconds, print ‘Fell off’ for that ant. Print an empty line after each test case.
Sample Input
2
10 1 4
1 R
5 R
3 L
10 R
10 2 3
4 R
5 L
8 R
Sample Output
Case #1:
2 Turning
6 R
2 Turning
Fell off
Case #2:
3 L
6 R
10 R
将蚂蚁看做一个个点,在蚂蚁相碰撞的时候可以看做穿透而过,最后可以得到所有点的最终为,而初始蚂蚁位于从小到大的第几个位置末态也同样位于几只蚂蚁的从左往右的那个位置。

#include <stdio.h>
#include <algorithm>
#include <string.h>
#include <iostream>
using namespace std;
struct Ant
{
    int p, d;
    int id;
    char c;
    bool operator<(const Ant &a) const
    {
        return p < a.p;
    }
} before[10020], after[10020];
char ans[3][10] = {"L", "Turning", "R"};
int order[10020];
int main()
{
#ifdef ONLINE_JUDGE
#else
    freopen("in.txt", "r", stdin);
#endif
    int i, j, n, k, t, l, p, d;
    char c;
    scanf("%d", &k);
    for (int kcase = 1; kcase <= k; kcase++)
    {
        scanf("%d%d%d", &l, &t, &n);
        for (i = 0; i < n; i++)
        {
            scanf("%d %c", &p, &c);
            before[i].id = i;
            before[i].p = p;
            before[i].c = c;
            d = (c == 'L' ? -1 : 1);
            before[i].d = d;
            after[i].p = p + t * d;
            after[i].c = c;
            after[i].d = d;
            after[i].id = 0;
        }
        sort(before, before + n);
        for (i = 0; i < n; i++)
        {
            order[before[i].id] = i;
        }
        sort(after, after + n);
        for (i = 1; i < n; i++)
        {
            if (after[i].p == after[i - 1].p)
            {
                after[i].c = 'T';
                after[i].d = 0;
                after[i-1].c = 'T';
                after[i-1].d = 0;
            }
        }
        printf("Case #%d:\n", kcase);
        for (i = 0; i < n; i++)
        {
            int a = order[i];
            if (after[a].p < 0 || after[a].p > l)
            {
                printf("Fell off\n");
            }
            else
            {
                printf("%d %s\n", after[a].p, ans[after[a].d + 1]);
            }
        }
        printf("\n");
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值