PAT 1005 Spell It Right (20分)

Given a non-negative integer N, your task is to compute the sum of all the digits of N, and output every digit of the sum in English.

Input Specification:
Each input file contains one test case. Each case occupies one line which contains an N (≤10^​100).

Output Specification:
For each test case, output in one line the digits of the sum in English words. There must be one space between two consecutive words, but no extra space at the end of a line.

Sample Input:

12345

Sample Output:

one five

数字与字符之间的转化

总结:
1、C语言中可以用sprintf将数字转化为字符数组,sscanf可以将字符数组格式化为数字。
eg:

int num = 12,temp;
char str[10];
sprintf(str,"%d",num);
sscanf(str,"%d",&temp);

2、C++中可以用string to_string(int num)将整型转化为string型,也可以将double转化为string等。

string str;
int num = 12;
str = to_string(num);

我的代码:

C:

#include<cstdio>
#include<cstring>
const int maxn = 110;
char word[10][10] = {"zero","one","two","three","four","five","six","seven","eight","nine"};
int getsum(char str[])
{
    int sum = 0;
    int len = strlen(str);
    for (int i = 0 ;i < len ;i++)
        sum += str[i] - '0';
    return sum;
}
void show(char str[])
{
    int len = strlen(str);
    for (int i = 0 ;i < len ;i++)
    {
        printf("%s",word[str[i] - '0']);
        if (i < len - 1)
            printf(" ");
    }   
}
int main()
{
    char str[maxn],temp[maxn];
    scanf("%s",str);
    int sum = getsum(str);
    sprintf(temp,"%d",sum);
    show(temp);
    return 0;
}

C++:

#include<cstdio>
#include<string>
#include<iostream>
using namespace std;
string word[10] = {"zero","one","two","three","four","five","six","seven","eight","nine"};
int getsum(string str)
{
    int sum = 0;
    for (int i = 0 ;i < str.size() ;i++)
        sum += str[i] - '0';
    return sum;
}
void show(string str)
{
    for (int i = 0 ;i < str.size() ;i++)
    {
        cout << word[str[i] - '0'];
        if (i < str.size() - 1)
            cout << " ";
    }   
}
int main()
{
    string str,temp;
    cin >> str;
    int sum = getsum(str);
    temp = to_string(sum);
    show(temp);
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

情书、

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值