PAT 1043 Is It a Binary Search Tree (25 分)

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

The left subtree of a node contains only nodes with keys less than the node’s key.
The right subtree of a node contains only nodes with keys greater than or equal to the node’s key.
Both the left and right subtrees must also be binary search trees.
If we swap the left and right subtrees of every node, then the resulting tree is called the Mirror Image of a BST.

Now given a sequence of integer keys, you are supposed to tell if it is the preorder traversal sequence of a BST or the mirror image of a BST.

Input Specification:
Each input file contains one test case. For each case, the first line contains a positive integer N (≤1000). Then N integer keys are given in the next line. All the numbers in a line are separated by a space.

Output Specification:
For each test case, first print in a line YES if the sequence is the preorder traversal sequence of a BST or the mirror image of a BST, or NO if not. Then if the answer is YES, print in the next line the postorder traversal sequence of that tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input 1:

7
8 6 5 7 10 8 11

Sample Output 1:

YES
5 7 6 8 11 10 8

Sample Input 2:

7
8 10 11 8 6 7 5

Sample Output 2:

YES
11 8 10 7 5 6 8

Sample Input 3:

7
8 6 8 5 10 9 11

Sample Output 3:

NO

我的代码:

建立二叉树,镜像二叉树再后序遍历

#include<cstdio>
#include<vector>
using namespace std;
const int maxn = 1010;
int temp[maxn],n;
vector<int> v,mv;
struct Node
{
    int data;
    Node *left,*right;
};
Node * newNode(int i)
{
    Node *root = new Node;
    root->data = i;
    root->right = root->left = NULL;
    return root;
}
void insert(Node *&root,int i)
{
    if (root == NULL)
    {
        root = newNode(i);
        return;
    }
    if (root->data <= i)
        insert(root->right,i);
    else
        insert(root->left,i);    
}
void mirrorinsert(Node *&mirroroot,int i)
{
    if (mirroroot == NULL)
    {
        mirroroot = newNode(i);
        return;
    }
    if (mirroroot->data > i)
        mirrorinsert(mirroroot->right,i);
    else
        mirrorinsert(mirroroot->left,i);   
}
void preorder(Node *root)
{
    v.push_back(root->data);
    if (root->left != NULL)
        preorder(root->left);
    if (root->right != NULL)
        preorder(root->right);
}
bool judge(Node *root)
{
    int i;
    v.clear();
    preorder(root);
    for(i = 0 ;i < n ;i++)
    {
        if (v[i] != temp[i])
            break;
    }
    if (i != n)
        return false;
    return true;
}
void postorder(Node *root)
{
    if (root->left != NULL)
        postorder(root->left);
    if (root->right != NULL)
        postorder(root->right);
    v.push_back(root->data);
}
int main()
{
    scanf("%d",&n);
    Node *root = NULL,*mirroroot = NULL;
    for (int i = 0 ;i < n ;i++)
    {
        int num;
        scanf("%d",&num);
        temp[i] = num;
        insert(root,num);
        mirrorinsert(mirroroot,num);
    }    
    if (judge(root) || judge(mirroroot))
    {
        if (judge(mirroroot))
            root = mirroroot;    
        printf("YES\n");
        v.clear();
        postorder(root);
        for (int i = 0 ;i < v.size() ;i++)
        {
            printf("%d",v[i]);
            if (i < v.size() - 1)
                printf(" ");
        }
    }
    else
        printf("NO");
    return 0;
}

直接由前序得后序,并判断

#include<cstdio>
#include<vector>
using namespace std;
vector<int> pre,post;
bool flag = true,ismir;
void getPost(int prel,int prer)
{
	if (prel > prer)
    	return;
    int i = prel + 1;
    if (ismir)
    {
    	while (i <= prer && pre[prel] <= pre[i]) i++;
        for (int j = i ;j <= prer ;j++)
        {
        	if (pre[prel] <= pre[j])
            	flag = false;
        }
     }
    else
    {
     	while (i <= prer && pre[prel] > pre[i]) i++;
        for (int j = i ;j <= prer ;j++)
        {
        	if (pre[prel] > pre[j])
            	flag = false;
        }            
     }
     int num = i - 1 - prel;
     getPost(prel + 1,prel + num);
     getPost(prel + num + 1,prer);
     post.push_back(pre[prel]);
}
int main()
{
    int n;
    scanf("%d",&n);
    for (int i = 0 ;i < n ;i++)
    {
        int num;
        scanf("%d",&num);
        pre.push_back(num);
    }
    ismir = false;
    getPost(0,pre.size() - 1);
    if (flag == false)
    {
        post.clear();
        ismir = flag = true;
        getPost(0,pre.size() - 1);
    }
    if (flag == true)
    {
        printf("YES\n");
        for (int i = 0 ;i < post.size() ;i++)
        {
            printf("%d",post[i]);
            if (i < post.size() - 1)
                printf(" ");
        }
    }
    else
        printf("NO\n");
    return 0;   
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

情书、

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值