HDU--ACMSteps--Leftmost Digit

Title:Leftmost Digit
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Problem Description
Given a positive integer N, you should output the leftmost digit of N^N.

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).

Output
For each test case, you should output the leftmost digit of N^N.

Sample Input
2
3
4

Sample Output
2
2

Hint
In the first case, 3 * 3 * 3 = 27, so the leftmost digit is 2.
In the second case, 4 * 4 * 4 * 4 = 256, so the leftmost digit is 2.

题目分析:
1、如果简单地用pow函数来求N^N,
显然范围不够,并且就算如果求出N^N,也会再求该结果的最高位数字上比较繁琐。所以应该换思维来思考这个问题。
2、借助数学分析:
一个数num,用科学计数法可以表示为num=a10^n,其中1<=a<10,且a即使我们所要求的num的Leftmost Digit。
输入数N
有NN=a*10n
借助数学变换:a=(NN)/(10n)…(1)
接下来分析法求解:要求a,则必须求n
对(1)式两边去以10为底的对数,则有:log10(a)=N
log10(N)-n;
又 1<=a<10,则0<=log10(a)<1且n为整数;所以n为N*log10(N)的整数部分。接下来在具体写代码中就是一些类型转换了。

代码如下:

#include<iostream>
#include<cmath>
using namespace std;
int main()
{
  int t;
  cin>>t;
  while(t--)
  {
  	double n,x;
  	cin>>n;
  	x=n*log10(n);
  	printf("%d\n",(int)pow(10.0,x-(long long)x));
  }
  return 0;
}

注意:
1、pow函数的形参类型以及其返回值类型。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值