HDU--ACMSteps--The area

Title:The area
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Problem Description
As we all know the Train Problem I, the boss of the Ignatius Train Station want to know if all the trains come in strict-increasing order, how many orders that all the trains can get out of the railway.

Input
The input contains several test cases. Each test cases consists of a number N(1<=N<=100). The input is terminated by the end of file.

Output
For each test case, you should output how many ways that all the trains can get out of the railway.

Sample Input
1
2
3
10

Sample Output
1
2
5
16796

Hint
The result will be very large, so you may not process it by 32-bit integers.

题目分析:
一开始那道题目并没有具体的思路,但是后面搜索了题解,发现这是一道考数学而不是编程思想的题目,编程思想的唯一体现就是处理数据的精度上。纯数学地计算相关参数,然后将面积用一个表达式表达出来就行了。

代码如下:

#include<iostream>
using namespace std;
int main()
{
	int t;
	cin>>t;
	double k,b,a;
	double s;
	double x1,y1,x2,y2,x3,y3;
	while(t--)
	{
		scanf("%lf%lf",&x1,&y1);
		scanf("%lf%lf",&x2,&y2);
		scanf("%lf%lf",&x3,&y3);
		k=(y3-y2)/(x3-x2);
		b=y3-k*x3;
		a=(y3-y1)/((x3-x1)*(x3-x1));
		s=(a*x3*x3*x3)/3-((2*a*x1+k)*x3*x3)/2+(a*x1*x1+y1-b)*x3-(a*x2*x2*x2)/3
		   +((2*a*x1+k)*x2*x2)/2-(a*x1*x1+y1-b)*x2;
		printf("%.2f\n",s);
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值