How Long Does It Take
Given the relations of all the activities of a project, you are supposed to find the earliest completion time of the project.
Input Specification:
Each input file contains one test case. Each case starts with a line containing two positive integers N (≤100), the number of activity check points (hence it is assumed that the check points are numbered from 0 to N−1), and M, the number of activities. Then M lines follow, each gives the description of an activity. For the i
-th activity, three non-negative numbers are given: S[i]
, E[i]
, and L[i]
, where S[i]
is the index of the starting check point, E[i]
of the ending check point, and L[i]
the lasting time of the activity. The numbers in a line are separated by a space.
Output Specification:
For each test case, if the scheduling is possible, print in a line its earliest completion time; or simply output "Impossible".
Sample Input 1:
9 12
0 1 6
0 2 4
0 3 5
1 4 1
2 4 1
3 5 2
5 4 0
4 6 9
4 7 7
5 7 4
6 8 2
7 8 4
Sample Output 1:
18
Sample Input 2:
4 5
0 1 1
0 2 2
2 1 3
1 3 4
3 2 5
Sample Output 2:
Impossible
解题思路
典型的AOE网络,如果所有点的出度都不是0,那么图就成环。如果有的节点没有访问到(孤立的点),也不可能完成活动。
max保存路径中节点花费的最长时间,最后输出就行了。
注意AOE更新时间的公式为:
d[i][j] = max(d[i][j] , d[i][t] + d[t][j])
代码如下:
#include<iostream>
#include<algorithm>
#include<vector>
#include<queue>
using namespace std;
struct node{
int in,out;
int visit;
};
int maxn(int a,int b){
if(a>b) return a;
return b;
}
int main(){
int n,m;
node v[100];//节点信息,包含节点的初度和入度
int g[100][100];//存储u图的信息
fill(g[0],g[0]+100*100,-55555);
vector<int> s; //存储所有入度为零的0,就是开始点。
scanf("%d %d",&n,&m);
for(int i=0;i<m;i++){
int v1,v2,e;
scanf("%d %d %d",&v1,&v2,&e);
v[v1].out = 1;v[v2].in = 1;g[v1][v2]=e;
v[v1].visit = v[v2].visit = 1;
}
int flag=0;
for (int i =0;i<n;i++){
//如果所有的节点都有出度,那么就是成环了。判断是否成环
if (v[i].out==0){
flag = 1;
}
//如果有节点没有访问到
if (v[i].visit == 0){
flag = 0;
}
if(v[i].in==0){
s.push_back(i);
}
}
if(!flag){
printf("Impossible");
return 0;
}
int max = -1;
for(int i=0;i<s.size();i++){
queue<int> q;
q.push(s[i]);
while(q.size()){
int t = q.front();
q.pop();
for(int j=0;j<n;j++){
if(g[t][j] != -55555){
g[s[i]][j] = maxn(g[s[i]][j],g[t][j] + g[s[i]][t]);
q.push(j);
if(max<g[s[i]][j]){
max = g[s[i]][j];
}
}
}
}
}
printf("%d",max);
return 0;
}