PAT甲级 1018 Public Bike Management (30 分)

4 篇文章 0 订阅
3 篇文章 0 订阅

There is a public bike service in Hangzhou City which provides great convenience to the tourists from all over the world. One may rent a bike at any station and return it to any other stations in the city.

The Public Bike Management Center (PBMC) keeps monitoring the real-time capacity of all the stations. A station is said to be in perfect condition if it is exactly half-full. If a station is full or empty, PBMC will collect or send bikes to adjust the condition of that station to perfect. And more, all the stations on the way will be adjusted as well.

When a problem station is reported, PBMC will always choose the shortest path to reach that station. If there are more than one shortest path, the one that requires the least number of bikes sent from PBMC will be chosen.

The above figure illustrates an example. The stations are represented by vertices and the roads correspond to the edges. The number on an edge is the time taken to reach one end station from another. The number written inside a vertex S is the current number of bikes stored at S. Given that the maximum capacity of each station is 10. To solve the problem at S3​, we have 2 different shortest paths:

  1. PBMC -> S1​ -> S3​. In this case, 4 bikes must be sent from PBMC, because we can collect 1 bike from S1​ and then take 5 bikes to S3​, so that both stations will be in perfect conditions.

  2. PBMC -> S2​ -> S3​. This path requires the same time as path 1, but only 3 bikes sent from PBMC and hence is the one that will be chosen.

Input Specification:

Each input file contains one test case. For each case, the first line contains 4 numbers: Cmax​ (≤100), always an even number, is the maximum capacity of each station; N (≤500), the total number of stations; Sp​, the index of the problem station (the stations are numbered from 1 to N, and PBMC is represented by the vertex 0); and M, the number of roads. The second line contains N non-negative numbers Ci​ (i=1,⋯,N) where each Ci​ is the current number of bikes at Si​ respectively. Then M lines follow, each contains 3 numbers: Si​, Sj​, and Tij​ which describe the time Tij​ taken to move betwen stations Si​ and Sj​. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print your results in one line. First output the number of bikes that PBMC must send. Then after one space, output the path in the format: 0−>S1​−>⋯−>Sp​. Finally after another space, output the number of bikes that we must take back to PBMC after the condition of Sp​ is adjusted to perfect.

Note that if such a path is not unique, output the one that requires minimum number of bikes that we must take back to PBMC. The judge's data guarantee that such a path is unique.

Sample Input:

10 3 3 5
6 7 0
0 1 1
0 2 1
0 3 3
1 3 1
2 3 1

结尾无空行

Sample Output:

3 0->2->3 0

结尾无空行

思路:dijkstra+dfs。本题的坑点在于调整只能在“去”的过程中而不能在“回”的过程中

#include <bits/stdc++.h>
using namespace std;
const int maxv=510;
const int inf=1e9;
int cmax,n,m,sp,maxback=inf,maxneed=inf;
int g[maxv][maxv],weight[maxv],d[maxv];
bool vis[maxv];
vector<int> pre[maxv];
vector<int> temp,path;
void Dijkstra(int s) //最短路径
{
    fill(d,d+maxv,inf);
    d[s]=0;
    for(int i=0;i<=n;i++)
    {
        int u=-1,minv=inf;
        for(int j=0;j<=n;j++)
        {
            if(!vis[j]&&d[j]<minv)
            {
                u=j;
                minv=d[j];
            }
        }
        if(u==-1) return;
        vis[u]=true;
        for(int v=0;v<=n;v++)
        {
            if(!vis[v]&&g[u][v]!=inf)
            {
                if(d[u]+g[u][v]<d[v])
                {
                    d[v]=d[u]+g[u][v];
                    pre[v].clear();
                    pre[v].push_back(u);
                }
                else if(d[u]+g[u][v]==d[v]) pre[v].push_back(u);
            }
        }
    }
}
void DFS(int v)//dfs回溯
{
    if(v==0)
    {
        temp.push_back(v);
        int sum=0,need=0;//sum表示空余车,need表示需要PBMC发出多少辆车
        for(int i=temp.size()-2;i>=0;i--) //PMBC不参与计算
        {
            if(weight[temp[i]]-cmax<0) //不足cmax/2
            {
                if(sum>0) //如果有在路径中收集的空余车
                {
                    if(sum>=abs(weight[temp[i]]-cmax)) sum-=abs(weight[temp[i]]-cmax); //够凑到camx/2
                    else //不够凑
                    {
                        need+=abs((weight[temp[i]]-cmax)+sum);
                        sum=0;
                    }
                }
                else need+=abs(weight[temp[i]]-cmax);
            }
            else sum+=(weight[temp[i]]-cmax);
        }
        if(need<maxneed)
        {
            maxneed=need;
            path=temp;
            maxback=sum;
        }
        else if((need==maxneed)&&(sum<maxback))
        {
            maxback=sum;
            path=temp;
        }
        temp.pop_back();
        return;
    }
    temp.push_back(v);
    for(int i=0;i<pre[v].size();i++) DFS(pre[v][i]);
    temp.pop_back();
}
int main()
{
    fill(g[0],g[0]+maxv*maxv,inf);
    fill(weight,weight+maxv,0);
    memset(vis,false,sizeof(vis));
    scanf("%d %d %d %d",&cmax,&n,&sp,&m);
    cmax/=2;
    for(int i=1;i<=n;i++) scanf("%d",&weight[i]);
    for(int i=0;i<m;i++)
    {
        int a,b,time;
        scanf("%d %d %d",&a,&b,&time);
        g[a][b]=g[b][a]=time;
    }
    Dijkstra(0);
    DFS(sp);
    printf("%d ",maxneed);
    for(int i=path.size()-1;i>=0;i--)
    {
        printf("%d",path[i]);
        if(i!=0) printf("->");
    }
    printf(" %d",maxback);
    return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值