PAT A1011. World Cup Betting (20)

1011 World Cup Betting (20 分)
With the 2010 FIFA World Cup running, football fans the world over were becoming increasingly excited as the best players from the best teams doing battles for the World Cup trophy in South Africa. Similarly, football betting fans were putting their money where their mouths were, by laying all manner of World Cup bets.

Chinese Football Lottery provided a “Triple Winning” game. The rule of winning was simple: first select any three of the games. Then for each selected game, bet on one of the three possible results – namely W for win, T for tie, and L for lose. There was an odd assigned to each result. The winner’s odd would be the product of the three odds times 65%.

For example, 3 games’ odds are given as the following:

W T L
1.1 2.5 1.7
1.2 3.1 1.6
4.1 1.2 1.1
To obtain the maximum profit, one must buy W for the 3rd game, T for the 2nd game, and T for the 1st game. If each bet takes 2 yuans, then the maximum profit would be (4.1×3.1×2.5×65−1)×2=39.31 yuans (accurate up to 2 decimal places).

Input Specification:
Each input file contains one test case. Each case contains the betting information of 3 games. Each game occupies a line with three distinct odds corresponding to W, T and L.

Output Specification:
For each test case, print in one line the best bet of each game, and the maximum profit accurate up to 2 decimal places. The characters and the number must be separated by one space.

Sample Input:
1.1 2.5 1.7
1.2 3.1 1.6
4.1 1.2 1.1
Sample Output:
T T W 39.31

题意:

给出三行比赛结果,从每一行选出一个最大值,并输出这个值对应的是W,T,还是L。假设这三个最大值为a,b,c,则计算最大收益(abc*0.65-1)*2并输出;

思路:

char 型数组s用来存放WTL,以便之后用数组下标输出字符。ans存放数据计算结果,temp临时存放输入数据中最大值,a存放临时输入数据。
外层for循环用来初始化最大值,里层循环用来记录最大值及其下标,最后按格式输出即可。

参考代码:

#include <cstdio>
char s[3]={'W','T','L'};
int main(){
	double ans=1.0,temp,a;
	int idx;
	for(int i=0;i<3;i++){//输入三行数据; 
		temp=0.0;
		for(int j=0;j<3;j++){//记录一行中最大的数及其下标 ; 
			scanf("%lf",&a);
			if(a>temp){
				temp=a;
				idx=j;
			}
		}
	ans*=temp;//计算相乘结果; 
	printf("%c ",s[idx]);	
	}
	printf("%.2f",(ans*0.65-1)*2);
	return 0;
} 

点评:

①此题属于查找元素型,英文题意也很好理解,按题意查找元素即可。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
As an AI language model, I can provide you with some guidance on how to implement a Texas Hold'em poker game in Clojure. However, I cannot write the entire code for you. Here are the general steps you can follow: 1. Define the data structures for the game, such as the deck of cards, player hands, and the community cards. 2. Write functions to shuffle the deck, deal the cards, and determine the winner of the game. 3. Implement the game logic, including the betting rounds, the flop, the turn, and the river. 4. Create a user interface for the game, which can be either a command-line interface or a graphical interface. Here is some sample Clojure code to get you started: ```clojure (def suits [:hearts :diamonds :clubs :spades]) (def ranks [:2 :3 :4 :5 :6 :7 :8 :9 :10 :J :Q :K :A]) (defn make-deck [] (for [suit suits rank ranks] {:suit suit :rank rank})) (defn shuffle-deck [deck] (shuffle deck)) (defn deal-hand [deck] (take 2 deck)) (defn deal-flop [deck] (take 3 (drop 2 deck))) (defn deal-turn [deck] (take 1 (drop 5 deck))) (defn deal-river [deck] (take 1 (drop 6 deck))) (defn evaluate-hand [hand community-cards] ;; Implement the hand evaluation logic here ) (defn determine-winner [hands community-cards] (let [evaluated-hands (map #(evaluate-hand % community-cards) hands) max-hand (apply max evaluated-hands)] (nth hands (.indexOf evaluated-hands max-hand)))) (defn play-game [] (let [deck (make-deck) shuffled-deck (shuffle-deck deck) player-hands (for [_ (range 4)] (deal-hand shuffled-deck)) flop (deal-flop shuffled-deck) turn (deal-turn shuffled-deck) river (deal-river shuffled-deck) community-cards (concat flop turn river)] (determine-winner player-hands community-cards))) ;; Example usage: (play-game) ``` This is just a basic implementation, and you will need to add more features to make it a fully functional game. Good luck!
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值