【PAT】1011. World Cup Betting (20)

题目描述:

With the 2010 FIFA World Cup running, football fans the world over were becoming increasingly excited as the best players from the best teams doing battles for the World Cup trophy in South Africa. Similarly, football betting fans were putting their money where their mouths were, by laying all manner of World Cup bets.

Chinese Football Lottery provided a “Triple Winning” game. The rule of winning was simple: first select any three of the games. Then for each selected game, bet on one of the three possible results – namely W for win, T for tie, and L for lose. There was an odd assigned to each result. The winner’s odd would be the product of the three odds times 65%.

For example, 3 games’ odds are given as the following:

W T L
1.1 2.5 1.7
1.2 3.0 1.6
4.1 1.2 1.1
To obtain the maximum profit, one must buy W for the 3rd game, T for the 2nd game, and T for the 1st game. If each bet takes 2 yuans, then the maximum profit would be (4.1*3.0*2.5*65%-1)*2 = 37.98 yuans (accurate up to 2 decimal places).

翻译:随着2010FIFA世界杯的到来,世界各地的足球迷都开始兴奋了起来,因为最强的队伍最强的球员将在南美争夺世界杯奖杯。相似的,足球赌迷将把钱投在所有世界杯赌球中可能获得金钱最多的地方。中国足彩提供了一种“三倍胜利”的游戏。胜利的规则很简单:首先选择任意三场游戏。然后对于每场选择的游戏,在三种可能的结果下赌注——W代表胜利,T代表平局,L代表失败。这里有一个每种结果对应的赔率。赢家的赔率为三个赔率的乘积乘以65%。
例如:三场比赛的赔率如下:
W T L
1.1 2.5 1.7
1.2 3.0 1.6
4.1 1.2 1.1
为了获得最高的收益,需要买第三场比赛的胜利,第二场比赛的平局,第一场比赛的平局。如果每次赌注花费2元,那么最大的收益为 (4.1*3.0*2.5*65%-1)*2 = 37.98 元。(保留两位小数)

INPUT FORMAT

Each input file contains one test case. Each case contains the betting information of 3 games. Each game occupies a line with three distinct odds corresponding to W, T and L.

翻译:每个输入文件包括一组测试数据。每组测试数据包括3场比赛的赔率信息。没场比赛提供一行包括W、T、L确定的赔率。

OUTPUT FORMAT

For each test case, print in one line the best bet of each game, and the maximum profit accurate up to 2 decimal places. The characters and the number must be separated by one space.

翻译:对于每组测试数据,输出一行包括每场比赛的最佳选择,和最大的收益保留两位小数。字母和数字之间必须由空格隔开。


Sample Input

1.1 2.5 1.7
1.2 3.0 1.6
4.1 1.2 1.1


Sample Output

T T W 37.98


解题思路

按照题目要求明显应该4舍5入,结果测试数据全是舍去,欺骗我感情。。。。如果要四舍五入的话可以通过加0.005实现。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<string>
#include<algorithm>
#define INF 99999999
using namespace std; 
char match[3]={'W','T','L'};
int m[3];
int main(){
    double a,Max,ans=1;
    for(int i=0;i<3;i++){
        Max=0;
        for(int j=0;j<3;j++){
            scanf("%lf",&a);
            if(Max<a)Max=a,m[i]=j;
        }
        ans*=Max;
    }
    ans=(ans*0.65-1)*2;
    for(int i=0;i<3;i++)printf("%c ",match[m[i]]);
    printf("%.2lf\n",ans);
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值