C++开平方根---求绝对值(HD)

开平方根
头文件:
#include <math.h>

  1. 方法一:
double sqrt(double x);//开平方sqrt是square root缩写

2.方法二:

double pow(double x,double y);//求乘方x^y,pow是power的缩写

实例:
求绝对值

Problem Description
求实数的绝对值。
 

Input
输入数据有多组,每组占一行,每行包含一个实数。
 

Output
对于每组输入数据,输出它的绝对值,要求每组数据输出一行,结果保留两位小数。
 

Sample Input
123
-234.00
 

Sample Output
123.00
234.00

#include <iostream>
#include <iomanip>
#include <algorithm>
#include <cmath>
using namespace std;
 int main()
{

    double x;
    while(cin>>x)
      {

            cout<<setiosflags(ios::fixed)<<setprecision(2)<<(double)sqrt(pow(x,2))<<endl;
      }
    return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值