1066 Root of AVL Tree (25分)

1066 Root of AVL Tree (25分)

An AVL tree is a self-balancing binary search tree. In an AVL tree, the heights of the two child subtrees of any node differ by at most one; if at any time they differ by more than one, rebalancing is done to restore this property. Figures 1-4 illustrate the rotation rules.

Now given a sequence of insertions, you are supposed to tell the root of the resulting AVL tree.
Input Specification:
Each input file contains one test case. For each case, the first line contains a positive integer N (≤20) which is the total number of keys to be inserted. Then N distinct integer keys are given in the next line. All the numbers in a line are separated by a space.

Output Specification:
For each test case, print the root of the resulting AVL tree in one line.

Sample Input 1:

5
88 70 61 96 120

Sample Output 1:

70

Sample Input 2:

7
88 70 61 96 120 90 65

Sample Output 2:

88

    #include<bits/stdc++.h>
    using namespace std;
    struct node{
        struct node *lchild,*rchild;
        int val;
    };
    node *rotateLeft(node *root){
        node *temp=root->rchild;
        root->rchild=temp->lchild;
        temp->lchild=root;
        return temp;
    }
    node *rotateRight(node *root){
        node *temp=root->lchild;
        root->lchild=temp->rchild;
        temp->rchild=root;
        return temp;
    }
    node *rotateLR(node *root){
        root->lchild=rotateLeft(root->lchild);
        return rotateRight(root);
    }
    node *rotateRL(node *root){
        root->rchild=rotateRight(root->rchild);
        return rotateLeft(root);
    }
    int getHeight(node *root){
        if(root==NULL)return 0;
        return max(getHeight(root->lchild),getHeight(root->rchild))+1;
    }
    node *insert(node *root,int val){
        if(root==NULL){
            root=new node;
            root->val=val;
            root->lchild=root->rchild=NULL;
        }
        else if(val<root->val){
            root->lchild=insert(root->lchild,val);
            if(getHeight(root->lchild)-getHeight(root->rchild)==2){
                root=val<root->lchild->val?rotateRight(root):rotateLR(root);
            }
        }
        else {
            root->rchild=insert(root->rchild,val);
            if(getHeight(root->lchild)-getHeight(root->rchild)==-2){
                root=val>root->rchild->val?rotateLeft(root):rotateRL(root);
            }
        }
        return root;
    }
    int main(){
        int N,val;
        node *root=NULL;
        cin>>N;
        while(N--){
            scanf("%d",&val);
            root=insert(root,val);
        }
        cout<<root->val;
        return 0; 
    }
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值