[PAT甲级] 1093 Count PAT‘s

The string APPAPT contains two PAT's as substrings. The first one is formed by the 2nd, the 4th, and the 6th characters, and the second one is formed by the 3rd, the 4th, and the 6th characters.

Now given any string, you are supposed to tell the number of PAT's contained in the string.

Input Specification:

Each input file contains one test case. For each case, there is only one line giving a string of no more than 105 characters containing only PA, or T.

Output Specification:

For each test case, print in one line the number of PAT's contained in the string. Since the result may be a huge number, you only have to output the result moded by 1000000007.

Sample Input:

APPAPT

Sample Output:

2

本题主要注意取余部分,如果写成sum +=(myVector[i].cntP * myVector[i].cntT) % 1000000007;就会出错;比如sum=1000000006,而myVector[i].cntP * myVector[i].cntT=10,则运算后sum超过1000000007而不是取余后的。

#include <iostream>
#include <vector>
using namespace std;
struct Position
{
    int cntP = 0, cntT = 0;
};
int main()
{
    string str;
    cin >> str;
    int cntP = 0, cntT = 0;
    vector<Position> myVector(str.size());
    for (int i = 0; i < str.size(); i++)
    {
        if (str[i] == 'P')
            cntP++;
        else if (str[i] == 'A')
            myVector[i].cntP = cntP;
    }
    for (int i = str.size() - 1; i >= 0; i--)
    {
        if (str[i] == 'T')
            cntT++;
        else if (str[i] == 'A')
            myVector[i].cntT = cntT;
    }
    int sum = 0;
    for (int i = 0; i < str.size(); i++)
        if (str[i] == 'A')
            sum = (sum + myVector[i].cntP * myVector[i].cntT) % 1000000007;
    cout << sum << endl;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值