【POJ2386】Lake Counting

Description
Due to recent rains, water has pooled in various places in Farmer John’s field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water (‘W’) or dry land (’.’). Farmer John would like to figure out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors.

Given a diagram of Farmer John’s field, determine how many ponds he has.

Input

  • Line 1: Two space-separated integers: N and M

  • Lines 2…N+1: M characters per line representing one row of Farmer John’s field. Each character is either ‘W’ or ‘.’. The characters do not have spaces between them.

Output

  • Line 1: The number of ponds in Farmer John’s field.

Sample Input

10 12
W........WW.
.WWW.....WWW
....WW...WW.
.........WW.
.........W..
..W......W..
.W.W.....WW.
W.W.W.....W.
.W.W......W.
..W.......W.

Sample Output
3

Hint
OUTPUT DETAILS:
There are three ponds: one in the upper left, one in the lower left,and one along the right side.

DFS基础题
题意中对八连通的理解比较重要,但也不难,连接起来的积水就只算成1片水洼

//Matsuri 
#include<cstdio>
#include<cmath>
#include<algorithm>
#include<iostream>
#define MAXN 110
using namespace std;
int m,n;char f[MAXN][MAXN];
int ans=0;
void dfs(int x,int y)
{
	f[x][y]='.';
	for (int dx=-1;dx<=1;dx++)
	{
		for (int dy=-1;dy<=1;dy++)
		{
			int mx=x+dx,my=y+dy;
			if (mx>=1 && mx<=n && my>=1 && my<=m && f[mx][my]=='W') //勿过界 
				dfs(mx,my);
		}
	}
	return;
}
void solve()
{
	for (int i=1;i<=n;i++)
	{
		for (int j=1;j<=m;j++)
		{
			if (f[i][j]=='W')
			{
				dfs(i,j);
				ans++;
			}	
		}	
	}
	printf("%d\n",ans);		
}
int main()
{
	while(scanf("%d%d",&n,&m)!=EOF)
	{
		ans=0;
		for (int i=1;i<=n;i++)
		{
			//getchar(); //巨坑,必须把上一行输入时最后的换行从输入缓冲区中清除
			for (int j=1;j<=m;j++)
			{
				while(f[i][j]=getchar(),f[i][j]!='.'&&f[i][j]!='W'); //或者这种写法也行
				//过滤掉了除'.'和'W'以外的所有输入	
			}			
		} 
		solve();
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值