poj Hopscotch (搜索)

16 篇文章 1 订阅

The cows play the child's game of hopscotch in a non-traditional way. Instead of a linear set of numbered boxes into which to hop, the cows create a 5x5 rectilinear grid of digits parallel to the x and y axes.

They then adroitly hop onto any digit in the grid and hop forward, backward, right, or left (never diagonally) to another digit in the grid. They hop again (same rules) to a digit (potentially a digit already visited).

With a total of five intra-grid hops, their hops create a six-digit integer (which might have leading zeroes like 000201).

Determine the count of the number of distinct integers that can be created in this manner.

Input

* Lines 1..5: The grid, five integers per line

Output

* Line 1: The number of distinct integers that can be constructed

Sample Input

1 1 1 1 1
1 1 1 1 1
1 1 1 1 1
1 1 1 2 1
1 1 1 1 1

Sample Output

15

Hint

OUTPUT DETAILS:

111111, 111112, 111121, 111211, 111212, 112111, 112121, 121111, 121112, 121211, 121212, 211111, 211121, 212111, and 212121 can be constructed. No other values are possible. 

给出一个 5*5 的方格,每个格子里有一个数字。从任意一个格子出发,可以跳向上下左右四个方向的其他格子,也可以从其他格子再跳回原地。跳5次,就可以构造出一个6位数,求所构成的不同的6位数的个数。

 

#include <iostream>
#include <cstdio>
#include <algorithm>
#define MAX 1000000
using namespace std;
int sum,w,h,dir[4][2]={{1,0},{0,1},{-1,0},{0,-1}};//dir是用来表示给你下一个可选择走的方向
int n, map[5][5];
int tag[MAX];
int DFS(int x,int y,int ans,int val)
{
    int xx,yy;
    if(ans==6)
    {
      tag[n++]=val;
      return 0;
    }
    val=val*10+map[x][y];
    for(int i=0;i<4;++i)
    {
        xx=x+dir[i][0],yy=y+dir[i][1];
        if(xx>=0&&xx<5&&yy>=0&&yy<5)
            DFS(xx,yy,ans+1,val);
    }
}
int main()
{
    n=0;
    int sum=1;
    for(int i=0;i<5;++i)
        for(int j=0;j<5;++j)
        cin>>map[i][j];
        for(int i=0;i<5;++i)
            for(int j=0;j<5;++j)
            DFS(i,j,0,0);
        sort(tag,tag+n);
        for(int i=1;i<n;++i)
        if(tag[i]!=tag[i-1])
            sum++;
        cout<<sum<<endl;
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值