UVA —10361—Automatic Poetry

题目描述

“Oh God”, Lara Croft exclaims, “it’s one of these dumb riddles again!”
In Tomb Raider XIV, Lara is, as ever, gunning her way through ancient Egyptian pyramids, prehistoric caves and medival hallways. Now she is standing in front of some important Germanic looking doorway and has to solve a linguistic riddle to pass. As usual, the riddle is not very intellectually challenging.
This time, the riddle involves poems containing a “Schuttelreim”. An example of a Schuttelreim is the following short poem:
Ein Kind halt seinen Schnabel nur,
wenn es hangt an der Nabelschnur.

The Problem
A Schuttelreim seems to be a typical German invention. The funny thing about this strange type of poetry is that if somebody gives you the first line and the beginning of the second one, you can complete the poem yourself. Well, even a computer can do that, and your task is to write a program which completes them automatically. This will help Lara concentrate on the “action” part of Tomb Raider and not on the “intellectual” part.

Input
The input will begin with a line containing a single number n. After this line follow n pairs of lines containing Schuttelreims. The first line of each pair will be of the form
s1s3s5
where the si are possibly empty strings of lowercase characters or blanks. The second line will be a string of lowercase characters or blanks ending with three dots “…”. Lines will we at most 100 characters long.

Output
For each pair of Schuttelreim lines l1 and l2 you are to output two lines c1 and c2 in the following way: c1 is the same as l1 only that the bracket marks “<” and “>” are removed. Line c2 is the same as l2, except that instead of the three dots the string
s4s3s2s5
should appear.

Sample Input

3
ein kind haelt seinen abel ur
wenn es haengt an der …
weil wir zu spaet zur <>oma amen
verpassten wir das …
u ist

Sample Output
ein kind haelt seinen schnabel nur
wenn es haengt an der nabel schnur
weil wir zu spaet zur oma kamen
verpassten wir das koma amen
du bist
bu dist


解题思路:

这个题以字符串的形式输入,判断<>中的内容,第一行输出直接去掉<>就行了,第二行把刚刚<>中的内容交换一下输出。

程序代码:

#include<stdio.h>
#include<string.h>
char s1[100],s2[100],c1[100],c2[100],l1[100],l2[100];
int main()
{
	int cad,n,i,j,k,m,t,a,b,e,f;
	scanf("%d",&cad);
	getchar();
	while(cad--)
	{
		memset(s1,0,sizeof(s1));
		memset(s2,0,sizeof(s2));
		memset(c1,0,sizeof(c1));
		memset(c2,0,sizeof(c2));
		memset(l1,0,sizeof(l1));
		memset(l2,0,sizeof(l2));
		fgets(s1,sizeof(s1),stdin);
		fgets(s2,sizeof(s2),stdin);
		n=strlen(s1);
		m=strlen(s2); 
		for(j=0;j<n;j++)
		{
			if(s1[j]=='<'||s1[j]=='>')
				continue;
			printf("%c",s1[j]);
		}
		for(i=n-1;i>=0;i--)
		{
			if(s1[i]=='>')
				a=i;
			if(s1[i]=='<')
			{
				b=i; break;
			}	
		}		
		for(i=0;i<n;i++)
		{
			if(s1[i]=='<')
				e=i;
			if(s1[i]=='>')
			{
				f=i; break;
			}
		}
		for(i=0;i<m;i++)
		{
			if(s2[i]=='.')
			{
				for(i=b+1;i<a;i++)
					printf("%c",s1[i]);
				for(i=f+1;i<b;i++)
					printf("%c",s1[i]);
				for(i=e+1;i<f;i++)
					printf("%c",s1[i]);
				for(i=a+1;i<n-1;i++)
					printf("%c",s1[i]);
				break;
			}
			else
				printf("%c",s2[i]);
		}
		printf("\n");			
	}
	return 0;
} 
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

我菜就爱学

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值