二分图之最大匹配数算法(Kindergarten)

最近又新学了一个算法叫二分匹配,其中有最大匹配数,最大独立集,最大顶点覆盖数、最大团等,不过还有的没有看懂(会看懂的,慢慢来)。
最大匹配数:最大匹配数指男女之间有关系的人最大匹配的个数是多少?
如:一共三男三女,一共有五种关系,分别是:
1 1’ ———— //一号女生和一号男生认识
1 2’ ————//一号女生与二号男生认识
2 2’ ————//二号女生与二号男生认识
2 3’ ————//二号女生和三号男生认识
3 1’ ————//三号女生和一号男生认识
求他们之间相互认识的最大匹配是多少?
模板代码:

#include<stdio.h>
#include<string.h>
int e[101][101];
int match[101],book[101];
int n,m;
int dfs(int u)
{
	int i;
	for(i=1;i<=n;i++)
	{
		if(book[i]==0&&e[u][i]==1)表示第i号男生没有匹配,且与u号女生认识
		{
			book[i]=1;//标记
			if(match[i]==0||dfs(match[i])==1)//如果点i未被标记或者找到了新的匹配
			{
				match[i]=u;//更新配对关系
				return 1;
			}
		}
	}
	return 0;
} 
int main()
{
	int i,j,t1,t2,sum=0;
	scanf("%d%d",&n,&m);
	for(i=1;i<=m;i++)
	{
		scanf("%d%d",&t1,&t2);
		e[t1][t2]=1;
	}
	mamset(match,0,sizeof(match));
	for(i=1;i<=n;i++)
	{
		memset(book,0,sizeof(book));//清空上次搜索时的标记
		if(dfs(i))
			sum++;
	}
	printf("%d\n",sum);
	return 0;
}
/*
6 5
1 4
1 5
2 5
2 6
3 4
*/

以下是一个例题讲解最大团:
题目: Kindergarten

In a kindergarten, there are a lot of kids. All girls of the kids know each other and all boys also know each other. In addition to that, some girls and boys know each other. Now the teachers want to pick some kids to play a game, which need that all players know each other. You are to
help to find maximum number of kids the teacher can pick.
Input
The input consists of multiple test cases. Each test case starts with a line containing three integers
G, B (1 ≤ G, B ≤ 200) and M (0 ≤ M ≤ G × B), which is the number of girls, the number of boys
and
the number of pairs of girl and boy who know each other, respectively.
Each of the following M lines contains two integers X and Y (1 ≤ X≤ G,1 ≤ Y ≤ B), which
indicates that girl X and boy Y know each other.
The girls are numbered from 1 to G and the boys are numbered from 1 to B.
The last test case is followed by a line containing three zeros.
Output
For each test case, print a line containing the test case number( beginning with 1) followed by a integer which is the maximum number of kids the teacher can pick.
Sample Input

2 3 3
1 1
1 2
2 3
2 3 5
1 1
1 2
2 1
2 2
2 3
0 0 0

Sample Output

Case 1: 3
Case 2: 4

解题思路:这个题是让算出两两之间都认识的最大的人数,也就是最 大团 的问 题 , 最大团=顶点数 - 最大独立集。

程序代码:

#include<iostream>
#include<string.h>
int e[2000][2000],match[5000],book[5000];
int n,m;
using namespace std;
int dfs(int u);
int main()
{
	int i,j,t1,t2,sum,k;
	int cas=1;
	while(cin>>n>>m>>k)
	{
		sum=0;
		if(n==0&&m==0&&k==0)
			break;
		memset(e,0,sizeof(e));
		for(i=1;i<=k;i++)
		{
			scanf("%d%d",&t1,&t2);
			e[t1][t2]=1;
		}
			memset(match,0,sizeof(match));
			for(i=1;i<=n;i++)
			{
				memset(book,0,sizeof(book));
				if(dfs(i))
					sum++;
			}
			printf("Case %d: %d\n",cas++,n+m-sum);
	}
	return 0;
}
int dfs(int u)
{
	int i;
	for(i=1;i<=m;i++)
	{
		if(book[i]==0&&e[u][i]==0)//匹配去寻找互相不认识的人
		{
			book[i]=1;
			if(match[i]==0||dfs(match[i]))
			{
				match[i]=u;//两两不认识的人匹配
				return 1;
			}
		}
	}
	return 0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

我菜就爱学

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值