Minimum Transport Cost

Minimum Transport Cost

 

These are N cities in Spring country. Between each pair of cities there may be one transportation track or none. Now there is some cargo that should be delivered from one city to another. The transportation fee consists of two parts: 
The cost of the transportation on the path between these cities, and 

a certain tax which will be charged whenever any cargo passing through one city, except for the source and the destination cities. 

You must write a program to find the route which has the minimum cost. 

Input

First is N, number of cities. N = 0 indicates the end of input. 

The data of path cost, city tax, source and destination cities are given in the input, which is of the form: 

a11 a12 ... a1N 
a21 a22 ... a2N 
............... 
aN1 aN2 ... aNN 
b1 b2 ... bN 

c d 
e f 
... 
g h 

where aij is the transport cost from city i to city j, aij = -1 indicates there is no direct path between city i and city j. bi represents the tax of passing through city i. And the cargo is to be delivered from city c to city d, city e to city f, ..., and g = h = -1. You must output the sequence of cities passed by and the total cost which is of the form: 

Output

From c to d : 
Path: c-->c1-->......-->ck-->d 
Total cost : ...... 
...... 

From e to f : 
Path: e-->e1-->..........-->ek-->f 
Total cost : ...... 

Note: if there are more minimal paths, output the lexically smallest one. Print a blank line after each test case. 
 

Sample Input

5
0 3 22 -1 4
3 0 5 -1 -1
22 5 0 9 20
-1 -1 9 0 4
4 -1 20 4 0
5 17 8 3 1
1 3
3 5
2 4
-1 -1
0

Sample Output

From 1 to 3 :
Path: 1-->5-->4-->3
Total cost : 21

From 3 to 5 :
Path: 3-->4-->5
Total cost : 16

From 2 to 4 :
Path: 2-->1-->5-->4
Total cost : 17

题解:这道题是让求出从a地到b地需要花费的最短路的最少费用,同时输出路径,这就需要判断最短路(Floyd模板)的同时记录路径,另外题目要求按字典序排除,那就要额外加一个条件,按字典序输出。

代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
#define inf 0x3f3f3f3f
int e[510][510],cost[510];
int n,re[510][510];
void floyd()
{
	int i,j,k;
	for(k=1;k<=n;k++)
	 for(i=1;i<=n;i++)
	  for(j=1;j<=n;j++)
	    if(e[i][j]>e[i][k]+e[k][j]+cost[k])
		  {
		  	e[i][j]=e[i][k]+e[k][j]+cost[k]; 
		  	re[i][j]=re[i][k];//记录路径 
		  }
		else
		{
			if(e[i][j]==e[i][k]+e[k][j]+cost[k]&&re[i][j]>re[i][k])//字典序 
			  re[i][j]=re[i][k];
		
	    }
}
int main()
{
	while(~scanf("%d",&n)&&n)
	{
		int i,j;
		for(i=1;i<=n;i++)
		 for(j=1;j<=n;j++)
		   {
		   	scanf("%d",&e[i][j]);
		   	if(e[i][j]==-1)//不存在这条路 
		   	  e[i][j]=inf;
		   	re[i][j]=j; 
		   }
		for(i=1;i<=n;i++)
		 scanf("%d",&cost[i]);
		floyd();
		int a,b;
		while(scanf("%d%d",&a,&b)&&(a!=-1||b!=-1))
		{
			int x=a,y=b;
			printf("From %d to %d :\nPath: %d",a,b,a);
			while(x!=y)
			{
				printf("-->%d",re[x][y]);
				x=re[x][y];
			}
			printf("\nTotal cost : %d\n\n",e[a][b]);
		}
	}
} 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值