PAT 1012

题目

1012 The Best Rank (25分)
To evaluate the performance of our first year CS majored students, we consider their grades of three courses only: C - C Programming Language, M - Mathematics (Calculus or Linear Algrbra), and E - English. At the mean time, we encourage students by emphasizing on their best ranks – that is, among the four ranks with respect to the three courses and the average grade, we print the best rank for each student.

For example, The grades of C, M, E and A - Average of 4 students are given as the following:

StudentID C M E A
310101 98 85 88 90
310102 70 95 88 84
310103 82 87 94 88
310104 91 91 91 91

Then the best ranks for all the students are No.1 since the 1st one has done the best in C Programming Language, while the 2nd one in Mathematics, the 3rd one in English, and the last one in average.

Input Specification:
Each input file contains one test case. Each case starts with a line containing 2 numbers N and M (≤2000), which are the total number of students, and the number of students who would check their ranks, respectively. Then N lines follow, each contains a student ID which is a string of 6 digits, followed by the three integer grades (in the range of [0, 100]) of that student in the order of C, M and E. Then there are M lines, each containing a student ID.

Output Specification:
For each of the M students, print in one line the best rank for him/her, and the symbol of the corresponding rank, separated by a space.

The priorities of the ranking methods are ordered as A > C > M > E. Hence if there are two or more ways for a student to obtain the same best rank, output the one with the highest priority.

If a student is not on the grading list, simply output N/A.

Sample Input:
5 6
310101 98 85 88
310102 70 95 88
310103 82 87 94
310104 91 91 91
310105 85 90 90
310101
310102
310103
310104
310105
999999

Sample Output:
1 C
1 M
1 E
1 A
3 A
N/A

题目很长,需要仔细阅读理解一下。
整个输入是先输入学生的成绩,后输入查询学生的id。
给每个学生的每门科目排名,不是对学生排名,是对科目排名,这个很重要。
输出要求输出这个学生排名最靠前的那门科目和那门科目的排名。

代码及思路

#include <iostream>
#include<cstdio>
#include<algorithm>
#include<cmath>
using namespace std;

struct Student {
	int id;
	int grade[4];
}stu[2010];

char course[4] = { 'A', 'C', 'M', 'E' };
int Rank[1000000][4] = { 0 };
int now;

bool cmp(Student a, Student b) {
	return a.grade[now] > b.grade[now];
}

int main() {
	int n, m;
	scanf("%d %d", &n, &m);
	for (int i = 0; i < n; i++) {
		scanf("%d %d %d %d", &stu[i].id, &stu[i].grade[1], &stu[i].grade[2], &stu[i].grade[3]);
		stu[i].grade[0] = round((stu[i].grade[1] + stu[i].grade[2] + stu[i].grade[3]) / 3 ) + 0.5;
	}
	for (now = 0; now < 4; now++) {
		sort(stu, stu + n, cmp);
		Rank[stu[0].id][now] = 1;
		for (int i = 1; i < n; i++) {
			if (stu[i].grade[now] == stu[i - 1].grade[now]) {
				Rank[stu[i].id][now] = Rank[stu[i - 1].id][now];
			}
			else {
				Rank[stu[i].id][now] = i + 1;
			}
		}
	}
	int request;
	int getcourse;
	int j = 0;
	for (int i = 0; i < m; i++) {
		scanf("%d", &request);
		if (Rank[request][0] == 0) {
			printf("N/A\n");
		}
		else {
			j = 0;
			getcourse = 0;
			int k = Rank[request][0];
			while (j < 4) {
				if (Rank[request][j] < k) {
					k = Rank[request][j];
					getcourse = j;
				}
				j++;
			}
			printf("%d %c\n", k, course[getcourse]);
		}
	}
	return 0;
}

思路:

  1. 使用cmp函数对于每门成绩将学生排名,即可得到该学生的科目排名,但要注意排名的次序是“1 1 3 4 5”这样,因为如果没有并列,则每个学生的排名就是在使用sort函数后的数组下标 + 1,只需要处理如果和前一个人分数相同的情况就行。
  2. 在排名之后,因为学生人数少于2000,但是id却是6位数且每个学生有五种属性(四个成绩加id),所以使用结构体来定义每个学生,然后创建一个排名数组Rank[id][i] ,其值表示学号为id的学生的第i个成绩的排名。
  3. 因为要求如果有同样的排名(比如某个学生在两门成绩都是第二),则按照A > C > M > E 这样的顺序,所以不如我们一开始就将下标从0~3定义为对应的A C M E。
  4. 在输出每个同学的信息时候,记得及时记录和更新记录变量,否则会导致在前几个学生输出后导致后面的学生出现错误(比如我的代码中的getcourse,j)。
  5. 对于小数的处理从题目中可以看出是四舍五入得到的,其实平均值的具体大小并不影响输出,题目所用到的测试用例基本上没有在平均值A这一项难为人,但是应该是四舍五入,用round函数加0.5即可。

其实本题的具体coding细节来自于算法笔记,思路和算法笔记基本一致但是在处理输出的过程中遇到了一些问题,所以参考过后按照算法笔记优化了代码和定义变量。

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值