PAT甲级1038(恢复最小数字)

1038 Recover the Smallest Number (30 point(s))

  Given a collection of number segments, you are supposed to recover the smallest number from them. For example, given { 32, 321, 3214, 0229, 87 }, we can recover many numbers such like 32-321-3214-0229-87 or 0229-32-87-321-3214 with respect to different orders of combinations of these segments, and the smallest number is 0229-321-3214-32-87.

Input Specification:
  Each input file contains one test case. Each case gives a positive integer N (≤10​4) followed by N number segments. Each segment contains a non-negative integer of no more than 8 digits. All the numbers in a line are separated by a space.

Output Specification:
  For each test case, print the smallest number in one line. Notice that the first digit must not be zero.

Sample Input:

5 32 321 3214 0229 87

Sample Output:

22932132143287

题目大意

  给定N个数字,可以任意拼凑,要求你输出最小数字

解题思路

  利用贪心策略,现考虑两个串s1,s2,如果s1+s2 < s2 + s1,则s1放在s2前,否则s2放在s1前,以此为排序规则进行排序,最后输出排序后的序列即可,注意要去除前导0,而且最后结果为0时,要输出0

代码

#include <iostream>
#include <string>
#include <vector>
#include <algorithm>
using namespace std;

bool cmp(string s1, string s2) {//排序规则
	return s1 + s2 < s2 + s1;
}
int main()
{
	int N, i;
	cin >> N;
	string num;
	vector<string> ivec;
	for (i = 0; i < N; ++i) {
		cin >> num;
		ivec.push_back(num);
	}
	sort(ivec.begin(), ivec.end(), cmp);
	int k = 0, flag = 0;
	for (auto it1 : ivec) {
		for (auto it2 : it1) {
			if (!flag && it2 != '0') {//如果遇到第一个非0,将flag置1
				flag = 1;
			}
			if (flag) {
				printf("%c", it2);
			}
		}
	}
	if (!flag) printf("0");//如果最终结果为0,要输出0
	return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值