Constructing Roads

There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are connected, if and only if there is a road between A and B, or there exists a village C such that there is a road between A and C, and C and B are connected.
We know that there are already some roads between some villages and your job is the build some roads such that all the villages are connect and the length of all the roads built is minimum.

Input
The first line is an integer N (3 <= N <= 100), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 1000]) between village i and village j.
Then there is an integer Q (0 <= Q <= N * (N + 1) / 2). Then come Q lines, each line contains two integers a and b (1 <= a < b <= N), which means the road between village a and village b has been built.

Output
You should output a line contains an integer, which is the length of all the roads to be built such that all the villages are connected, and this value is minimum.

Sample Input
3
0 990 692
990 0 179
692 179 0
1
1 2

Sample Output
179

分析:解决本问题会用到并查集、结构体以及排序的相关知识,有模板可以套用,下面代码里还会有一些注释。

代码如下:

#include"iostream"
#include"set"
#include"algorithm"
using namespace std;
int pre[1005];
void init()
{
	for(int i=0;i<=1000;i++)
	{
		pre[i]=i;
	}
}
int find(int x)//并查集 ,查找上级 
{
	return x == pre[x] ? x:pre[x]=find(pre[x]);//简便写法 
}
/*int find(int x)//并查集,查找上级 
{
	int r=x;
	while(pre[r]!=r)//一个人的上级不是自己时 
	{                                               
	    r=pre[r];//逐集上查 
	}
	int k=x,j;
	while(k!=r)
	{
		j=pre[k];
		pre[k]=r;
		k=j;
	 } 
	return r;//找到上级 
}*/
int pjoin(int x,int y)//放在一个集合里面,只要一个上级 
{
	int fx=find(x);
	int fy=find(y);//两个人的两个上级 
	if(fx!=fy)
	{
		pre[fx]=fy;//两个上级中的任意一个认另外一个为上级 
		return 1;
	}
	return 0;
}
void djoin(int x,int y)
{
	int fx=find(x);
	int fy=find(y);
	if(fx!=fy)
	{
		pre[fx]=fy;
	}
}
struct Point//结构体
{
	int x,y,u;
};
int cmp (Point a,Point b)
{
	return a.u<b.u;
}
int main()
{
	Point p[10000];
	int n;//村子的个数 
	while(cin>>n)
	{
		init();
		int l=0;
		for(int i=0;i<n;i++)
		{
			for(int j=0;j<n;j++)
			{
				int X;
				cin>>X;
				if(i==j)
				{
					continue;
				}
				p[l].x=i;
				p[l].y=j;
				p[l].u=X;
				l++;
			}
		}
		int b;
		cin>>b;
		while(b--)
		{
			int X,Y;
			cin>>X>>Y;
			X--;
			Y--;
			djoin(X,Y);
		} 
		sort(p,p+l,cmp);//排序 
		int sum=0,f=0;
		for(int i=0;i<l;i++)
		{
			if(pjoin(p[i].x,p[i].y))
			{
				sum+=p[i].u;
				f++;
			}
		}
		cout<<sum<<endl;
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
引用\[1\]:出现如下报错信息: \[ INFO\] \[1564730909.628248268\]: Constructing new MoveGroup connection for group 'arm_group' in namespace '' \[ INFO\] \[1564730910.984667942\]: MoveItSimpleControllerManager: Waiting for redwall_arm/follow_joint_trajectory to come up \[ERROR\] \[1564730915.984849668\]: MoveItSimpleControllerManager: Action client not connected: redwall_arm/follow_joint_trajectory \[ INFO\] \[1564730916.087709422\]: Returned 0 controllers in list \[ INFO\] \[1564730916.107154984\]: Trajectory execution is managing controllers 。 引用\[2\]:发现竟然没有找到follow_joint_trajectory消息,难道move_group没有发布吗?纠结了一天,终于找到原因了,之前虚拟机械臂有gazebo的ros_control插件自动帮我们获取了follow_joint_trajectory的动作action信息,现在到真实机器人了,需要我们自己写程序了。问题找到了,最重要的是要理解一点,move_group此时是follow_joint_trajectory的client端,动作消息是client端的move_group发布的,听起来有点绕,但是千万不要把报错信息的action client not connect搞混淆了,我们现在client是存在且被感知的(就是move_group),而之所以报错是因为我缺少了action server端,我们需要添加一个server订阅这个action。 引用\[3\]:Animation Blueprints Exposed types on SkeletalControlBase to allow creation of derived classes.Added support for creating sub-classes of FAnimNode_StateMachine outside Engine module.Allowed UAnimNotify_PlayMontageNotify to be inherited by other modules.Bug Fix:Fixed sub-classes of FAnimNode_SkeletalControlBase not having deprecated CacheBones called。 问题:constructing new movegroup connection for group 'manipulator' in namespace 回答: 根据提供的引用内容,报错信息中显示正在构建一个新的MoveGroup连接,连接的组是'manipulator',命名空间为空。\[1\]这个报错信息表明正在尝试建立一个名为'manipulator'的组的MoveGroup连接。然而,报错信息中还显示了一个错误,即Action client 'redwall_arm/follow_joint_trajectory'未连接。\[2\]这可能是因为缺少一个action server端,需要添加一个server来订阅这个action。根据提供的信息,还无法确定是否已经在命名空间中找到了'manipulator'组的相关信息。 #### 引用[.reference_title] - *1* *2* [通过ROS控制真实机械臂(5)---Moveit!真实机械臂(move_group和demo.launch修改)](https://blog.csdn.net/qq_34935373/article/details/95916111)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v91^insert_down28v1,239^v3^insert_chatgpt"}} ] [.reference_item] - *3* [Unreal Engine 4.20 Release Notes](https://blog.csdn.net/pizi0475/article/details/81636150)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v91^insert_down28v1,239^v3^insert_chatgpt"}} ] [.reference_item] [ .reference_list ]

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值