Constructing Roads

There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are connected, if and only if there is a road between A and B, or there exists a village C such that there is a road between A and C, and C and B are connected.
We know that there are already some roads between some villages and your job is the build some roads such that all the villages are connect and the length of all the roads built is minimum.

Input
The first line is an integer N (3 <= N <= 100), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 1000]) between village i and village j.
Then there is an integer Q (0 <= Q <= N * (N + 1) / 2). Then come Q lines, each line contains two integers a and b (1 <= a < b <= N), which means the road between village a and village b has been built.

Output
You should output a line contains an integer, which is the length of all the roads to be built such that all the villages are connected, and this value is minimum.

Sample Input
3
0 990 692
990 0 179
692 179 0
1
1 2

Sample Output
179

分析:解决本问题会用到并查集、结构体以及排序的相关知识,有模板可以套用,下面代码里还会有一些注释。

代码如下:

#include"iostream"
#include"set"
#include"algorithm"
using namespace std;
int pre[1005];
void init()
{
	for(int i=0;i<=1000;i++)
	{
		pre[i]=i;
	}
}
int find(int x)//并查集 ,查找上级 
{
	return x == pre[x] ? x:pre[x]=find(pre[x]);//简便写法 
}
/*int find(int x)//并查集,查找上级 
{
	int r=x;
	while(pre[r]!=r)//一个人的上级不是自己时 
	{                                               
	    r=pre[r];//逐集上查 
	}
	int k=x,j;
	while(k!=r)
	{
		j=pre[k];
		pre[k]=r;
		k=j;
	 } 
	return r;//找到上级 
}*/
int pjoin(int x,int y)//放在一个集合里面,只要一个上级 
{
	int fx=find(x);
	int fy=find(y);//两个人的两个上级 
	if(fx!=fy)
	{
		pre[fx]=fy;//两个上级中的任意一个认另外一个为上级 
		return 1;
	}
	return 0;
}
void djoin(int x,int y)
{
	int fx=find(x);
	int fy=find(y);
	if(fx!=fy)
	{
		pre[fx]=fy;
	}
}
struct Point//结构体
{
	int x,y,u;
};
int cmp (Point a,Point b)
{
	return a.u<b.u;
}
int main()
{
	Point p[10000];
	int n;//村子的个数 
	while(cin>>n)
	{
		init();
		int l=0;
		for(int i=0;i<n;i++)
		{
			for(int j=0;j<n;j++)
			{
				int X;
				cin>>X;
				if(i==j)
				{
					continue;
				}
				p[l].x=i;
				p[l].y=j;
				p[l].u=X;
				l++;
			}
		}
		int b;
		cin>>b;
		while(b--)
		{
			int X,Y;
			cin>>X>>Y;
			X--;
			Y--;
			djoin(X,Y);
		} 
		sort(p,p+l,cmp);//排序 
		int sum=0,f=0;
		for(int i=0;i<l;i++)
		{
			if(pjoin(p[i].x,p[i].y))
			{
				sum+=p[i].u;
				f++;
			}
		}
		cout<<sum<<endl;
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值