POJ3784(对顶堆做法)

                                                                                  Running Median

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 5096 Accepted: 2270

Description

For this problem, you will write a program that reads in a sequence of 32-bit signed integers. After each odd-indexed value is read, output the median (middle value) of the elements received so far.

Input

The first line of input contains a single integer P, (1 ≤ P ≤ 1000), which is the number of data sets that follow. The first line of each data set contains the data set number, followed by a space, followed by an odd decimal integer M, (1 ≤ M ≤ 9999), giving the total number of signed integers to be processed. The remaining line(s) in the dataset consists of the values, 10 per line, separated by a single space. The last line in the dataset may contain less than 10 values.

Output

For each data set the first line of output contains the data set number, a single space and the number of medians output (which should be one-half the number of input values plus one). The output medians will be on the following lines, 10 per line separated by a single space. The last line may have less than 10 elements, but at least 1 element. There should be no blank lines in the output.

Sample Input

3 
1 9 
1 2 3 4 5 6 7 8 9 
2 9 
9 8 7 6 5 4 3 2 1 
3 23 
23 41 13 22 -3 24 -31 -11 -8 -7 
3 5 103 211 -311 -45 -67 -73 -81 -99 
-33 24 56

Sample Output

1 5
1 2 3 4 5
2 5
9 8 7 6 5
3 12
23 23 22 22 13 3 5 5 3 -3 
-7 -3

题解:运用了对顶堆的做法,前一部分数列储存在大根堆中,后一部分数列存储在小根堆中,同时每一次对两个二叉堆的元素的数量进行维护。

#include<iostream>
#include<algorithm>
#include<queue>
using namespace std;
#define ll long long
#define rint register int 
int main() {
	ios::sync_with_stdio(false);
	cin.tie(0);
  priority_queue<int> q;
  priority_queue<int,vector<int>,greater<int> > p;
  int t,n,m,a[10002];
  cin >> t;
  while(t--) {
  	int cnt = 0;
  	while(q.size()){
  		q.pop();
	  }
	  while(p.size()) {
	  	p.pop();
	  }
  	 cin >> n >> m;
	 for(int i=0;i<m;i++) {
	 	cin >> a[i];
	 }
	 cout << n << ' ' << (m+1)/2 << endl;
	 for(int i=0;i<m;i++) {
	 	 if(i == 0) {
	 	 	cout << a[i] << ' ';
	 	 	cnt++;
	 	 	 p.push(a[i]);
	 	 	 continue;
		  } 
		 int x = p.top();
		 if(a[i] < x) {
		 	q.push(a[i]);
		 }else{
		 	p.push(a[i]);
		 }
		 if(q.size()>p.size()) {
		 	while(q.size()>p.size()) {
		 		 x = q.top();
		 		 q.pop();
		 		 p.push(x);
			}
		 }else{
		 	while(p.size()>q.size()) {
		 		 x = p.top();
		 		 p.pop();
		 		 q.push(x);
			 }
			if(p.size()<q.size()) {
				x = q.top();
				p.push(x);
				q.pop();
			}
		 }
		 if(i%2 == 0) {
		 	cnt++;
		 	if(cnt%10!=0)
		 	cout << p.top() << ' ';
		 	else
		 	cout << p.top() <<'\n';
		 } 
	 }
	 cout << endl;
	 //puts(""); 
  }  
  return 0;
} 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值