A strange lift (深搜加剪枝)

本文探讨了一个奇特的电梯问题,电梯可以在任意楼层停靠,并且每个楼层有一个整数Ki,按下上按钮会前往i+Ki层,下按钮则前往i-Ki层。当在A楼想要前往B楼时,如何最少次数按下按钮?这个问题涉及到路径规划和剪枝算法。通过深度优先搜索策略,可以找到从A楼到B楼的最短路径。然而,如果无法到达B楼,则输出-1。示例中给出了一个包含五层楼和特定Ki值的例子,展示了如何计算最少的按钮按压次数。
摘要由CSDN通过智能技术生成
 There is a strange lift.The lift can stop can at every floor as you want, and there is a number Ki(0 <= Ki <= N) on every floor.The lift have just two buttons: up and down.When you at floor i,if you press the button "UP" , you will go up Ki floor,i.e,you will go to the i+Ki th floor,as the same, if you press the button "DOWN" , you will go down Ki floor,i.e,you will go to the i-Ki th floor. Of course, the lift can't go up high than N,and can't go down lower than 1. For example, there is a buliding with 5 floors, and k1 = 3, k2 = 3,k3 = 1,k4 = 2, k5 = 5.Begining from the 1 st floor,you can press the button "UP", and you'll go up to the 4 th floor,and if you press the button "DOWN", the lift can't do it, because it can't go down to the -2 th floor,as you know ,the -2 th floor isn't exist.
Here comes the problem: when you are on floor A,and you want to go to floor B,how many times at least he has to press the button "UP" or "DOWN"?

Input
The input consists of several test cases.,Each test case contains two lines.
The first line contains three integers N ,A,B( 1 <= N,A,B <= 200) which describe above,The second line consist N integers k1,k2,…kn.
A single 0 indicate the end of the input.
Output
For each case of the input output a interger, the least times you have to press the button when you on floor A,and you want to go to floor B.If you can’t reach floor B,printf “-1”.
Sample Input

5 1 5
3 3 1 2 5
0

Sample Output

3

本题剪枝时要注意顺序,如果顺序不对也可能会导致答案错误。

#include<stdio.h>
#include<string.h>
int N, A, B;
int a[300], book[300];
int min, flat;
void dfs(int n, int count)
{
	if(n==B&&count<min)//若能到达目标楼层,将其标记并记录时间 
	{
		min=count;
		flat=1;
		return;
	}
	if(count>min)//若现在所用时间大于上次所用时间 
		return; 
	if(count>=book[n])//若当前楼层已来过 且所用时间大于上次所用时间 
		return;
	book[n]=count;//记录到达每层的时间 
	dfs(n+a[n],count+1);//向上移动 
	dfs(n-a[n],count+1);//向下移动 
		if(n>N||n<1)//如果大于最高楼层或小于一楼 
	 	 return;
	return;
}
int main()
{
	while(1)
	{
		scanf("%d",&N);
		if(N==0)
		break;
		scanf("%d%d",&A,&B);
		min=9999999;
		flat=0;
		for(int i=1; i<=N; i++)
		{
			book[i]=9999999;
			scanf("%d",&a[i]);
		}
		dfs(A,0);//从当前楼层开始深搜 
		if(flat==1)
		printf("%d\n",min);
		else
		printf("-1\n"); 
	}
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值