Dollar Dayz---动态规划

http://poj.org/problem?id=3181 

 

Farmer John goes to Dollar Days at The Cow Store and discovers an unlimited number of tools on sale. During his first visit, the tools are selling variously for $1, $2, and $3. Farmer John has exactly $5 to spend. He can buy 5 tools at $1 each or 1 tool at $3 and an additional 1 tool at $2. Of course, there are other combinations for a total of 5 different ways FJ can spend all his money on tools. Here they are: 

        1 @ US$3 + 1 @ US$2

        1 @ US$3 + 2 @ US$1

        1 @ US$2 + 3 @ US$1

        2 @ US$2 + 1 @ US$1

        5 @ US$1

Write a program than will compute the number of ways FJ can spend N dollars (1 <= N <= 1000) at The Cow Store for tools on sale with a cost of $1..$K (1 <= K <= 100).

Input

A single line with two space-separated integers: N and K.

Output

A single line with a single integer that is the number of unique ways FJ can spend his money.

Sample Input

5 3

Sample Output

5

 题意:给出两个数,n,k,问k以内的整数有多少种组成n的方法
这位大佬讲的很详细!可以看看!
 

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
const long long flag=1000000000000000000;///long long型能存19位数1000 0000 0000 0000 000
long long a[1010],b[1010];///高位  低位    1.84*10^19
int main()
{
    int n,k;
    while(~scanf("%d %d",&n,&k))
    {
        memset(a,0,sizeof(a));
        memset(b,0,sizeof(b));
        b[0]=1;                    ///低位赋初值
        for(int i=1; i<=k; i++)
        {
            for(int j=i; j<=n; j++)
            {
                a[j]+=a[j-i];
                b[j]+=b[j-i];
                if(b[j]>=flag)
                {
                    a[j]+=b[j]/flag;
                    b[j]%=flag;
                }
            }
        }
        if(a[n])                   ///判断有高位就输出高位
            printf("%lld",a[n]);
        printf("%lld\n",b[n]);
    }
    return 0;
}

 

没有人可以走捷径,也没有人可以随随便便成功!

有人说,能吃苦是一种素质,敢吃苦是一种境界,吃过苦是一笔财富!我觉得,一次又一次的坚持,一次又一次的砥砺前行,让人才能逐渐变得强大!

临渊羡鱼,不如退而结网;扬汤止沸,不如釜底抽薪

  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

嵩韵儿

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值