A - 大菲波数

A - 大菲波数

Fibonacci数列,定义如下:
f(1)=f(2)=1
f(n)=f(n-1)+f(n-2) n>=3。
计算第n项Fibonacci数值。

Input
输入第一行为一个整数N,接下来N行为整数Pi(1<=Pi<=1000)。

Output
输出为N行,每行为对应的f(Pi)。
Sample Input
5
1
2
3
4
5
Sample Output
1
1
2
3
5

运用JAVA大数解决

代码:

import java.util.Scanner;
public class Main {
	public static void main(String args[]) {
		Scanner reader =new Scanner(System.in);
		int n;
		n=reader.nextInt();
		BigInteger [] a= new BigInteger[1010];	
		a[1] = new BigInteger("1");
		a[2]= new BigInteger("1");
		int m;
		for(int j=3;j<=1000;j++) {
			a[j]=a[j-1].add(a[j-2]);
		}
		for(int i=1;i<=n;i++) {
			m=reader.nextInt();
			System.out.println(a[m]);
			
		}
	}
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值