UVA-272 TEX Quotes 字符串处理

Description

原题链接🔗:UVA-272

TEX is a typesetting language developed by Donald Knuth. It takes source text together with a few typesetting instructions and produces, one hopes, a beautiful document. Beautiful documents use “ and ” to delimit quotations, rather than the mundane " which is what is provided by most keyboards. Keyboards typically do not have an oriented double-quote, but they do have a left-single-quote ` and a right-single-quote ‘. Check your keyboard now to locate the left-single-quote key ` (sometimes called the “backquote key”) and the right-single-quote key ’ (sometimes called the “apostrophe” or just “quote”). Be careful not to confuse the left-single-quote ` with the “backslash” key . TEX lets the user type two left-single-quotes `` to create a left-double-quote “ and two right-single-quotes ‘’ to create a right-double-quote ”. Most typists, however, are accustomed to delimiting their quotations with the un-oriented double-quote ". If the source contained “To be or not to be,” quoth the bard, “that is the question.” then the typeset document produced by TEX would not contain the desired form: “To be or not to be,” quoth the bard, “that is the question.” In order to produce the desired form, the source file must contain the sequence: ``To be or not to be,’’ quoth the bard, ``that is the question.’’ You are to write a program which converts text containing double-quote (") characters into text that is identical except that double-quotes have been replaced by the two-character sequences required by TEX for delimiting quotations with oriented double-quotes. The double-quote (") characters should be replaced appropriately by either `` if the " opens a quotation and by ‘’ if the " closes a quotation. Notice that the question of nested quotations does not arise: The first " must be replaced by ``, the next by ‘’, the next by ``, the next by ‘’, the next by ``, the next by ‘’, and so on.

Sample Input

“To be or not to be,” quoth the Bard, “that is the question”. The
programming contestant replied: "I must disagree. To `C’ or not to
`C’, that is The Question!

Sample Output

``To be or not to be,’’ quoth the Bard, ``that is the question’’.
The programming contestant replied: ``I must disagree. To `C’ or
not to `C’, that is The Question!’’

题目大意:

在Tex这种编辑方式下,需要将左引号是’ " ’ 将其转化为’ `` ‘,右引号’ " ’ 将其转化为’ ‘’ ';将整篇文章中的引号转换后输出文章。处理方式很简单,直接上代码。

AC代码

#include <iostream>
#include <stdio.h>
using namespace std;
const int maxn = 1e3 + 5;
int main()
{
    char c;
    int flag = 0;
    while (scanf("%c", &c) != EOF)
    {
        if (c == '"')
        {
            if (flag == 0) //第一次
            {
                c = '`';
                printf("%c%c", c, c);
                flag = 1;
            }
            else // 第二次
            {
                c = '\'';
                printf("%c%c", c, c);
                flag = 0;
            }
        }
        else
        {
            printf("%c", c);
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值