FZU - 2150 -- Fire Game【两头BFS】

Fire Game
Description

Fat brother and Maze are playing a kind of special (hentai) game on an N*M board (N rows, M columns). At the beginning, each grid of this board is consisting of grass or just empty and then they start to fire all the grass. Firstly they choose two grids which are consisting of grass and set fire. As we all know, the fire can spread among the grass. If the grid (x, y) is firing at time t, the grid which is adjacent to this grid will fire at time t+1 which refers to the grid (x+1, y), (x-1, y), (x, y+1), (x, y-1). This process ends when no new grid get fire. If then all the grid which are consisting of grass is get fired, Fat brother and Maze will stand in the middle of the grid and playing a MORE special (hentai) game. (Maybe it’s the OOXX game which decrypted in the last problem, who knows.)

You can assume that the grass in the board would never burn out and the empty grid would never get fire.

Note that the two grids they choose can be the same.

Input

The first line of the date is an integer T, which is the number of the text cases.

Then T cases follow, each case contains two integers N and M indicate the size of the board. Then goes N line, each line with M character shows the board. “#” Indicates the grass. You can assume that there is at least one grid which is consisting of grass in the board.

1 <= T <=100, 1 <= n <=10, 1 <= m <=10

Output

For each case, output the case number first, if they can play the MORE special (hentai) game (fire all the grass), output the minimal time they need to wait after they set fire, otherwise just output -1. See the sample input and output for more details.

Sample Input

  4
  3 3
  .#.
  ###
  .#.
  3 3
  .#.
  #.#
  .#.
  3 3
  …
  #.#
  …
  3 3
  ###
  …#
  #.#

Sample Output

Case 1: 1
Case 2: -1
Case 3: 0
Case 4: 2

题意
有一个n*m的操场,"#"代表着草,“.“代表空格不能燃烧,两兄弟将点燃这些草并且火往四周开始蔓延。
他们只能选择两个位置(可以是相同的位置),开始点燃草,求将这些草烧完过后需要的最短时间t。如果不能烧完就输出-1。
思路
先是想着两头bfs的,但是不知道走那两头,没想到是暴力地图上的任意两个草的位置。
用vis起到起点到此位置的最短距离,并且起到了标记作用,枚举的下一个位置距离比上一个大避免往回走。 
复杂度分析:
O(k^2 * n * m) k代表"#"的个数 
AC代码
#include<cstdio>
#include<iostream>
#include<queue>
#include<cstring>
#include<vector>
#include<algorithm>
using namespace std;
const int inf = 0x3f3f3f;
struct node{
	int x, y;
	node(int _x, int _y){
		x = _x;
		y = _y;
	}
};
vector<node> v;
char mp[15][15];
int vis[15][15];
int dir[4][2] = {{1, 0}, {-1, 0}, {0, 1}, {0, -1}};
int n, m;
int bfs(int sx, int sy, int ex, int ey){
	queue<node> q;
	memset(vis, inf, sizeof(vis));
	q.push(node(sx, sy));
	q.push(node(ex, ey));
	vis[sx][sy] = 0;
	vis[ex][ey] = 0;
	while (!q.empty()){
		node now = q.front(); q.pop();
		for (int i = 0; i < 4; ++i){
			int dx = now.x + dir[i][0];
			int dy = now.y + dir[i][1];
			if (dx < 0 || dy < 0 || dx >= n || dy >= m || mp[dx][dy] == '.' || vis[dx][dy] <= vis[now.x][now.y] + 1)	continue;
			vis[dx][dy] = vis[now.x][now.y] + 1;
			q.push(node(dx, dy));
		}
	}
	int res = 0;
	for(int i = 0; i < v.size(); ++i){
		res = max(res, vis[v[i].x][v[i].y]);
	}
	return res;
}
void solve(int t){
	v.clear();
	scanf("%d%d", &n, &m);
	for (int i = 0; i < n; ++i){
		for (int j = 0; j < m; ++j){
			scanf(" %c", &mp[i][j]);
			if (mp[i][j] == '#'){
				v.push_back(node(i, j));
			}
		}
	}
	int ans = inf;
	for (int i = 0; i < v.size(); ++i){
		for (int j = 0; j < v.size(); ++j){
			ans = min(ans, bfs(v[i].x, v[i].y, v[j].x, v[j].y));
		}
	}
	printf("Case %d: ", t);
	if (ans == inf){
		ans = -1;
	}
	printf("%d\n", ans);
}
int main(){
	int t;
	scanf("%d", &t);
	for (int i = 1; i <= t; ++i)	solve(i);
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

星空皓月

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值