Inverted Deck

  •  5000ms
  •  262144K

As a huge fan of the popular collectible card game Numinous Wilds: the Elven Reign Chronicles (NWERC), you have a large collection of cards which you carefully organise by their rarity. One day you notice that someone has touched your collection, and that some of the cards are now out of order. The most natural suspect, of course, is your little brother Billy, who was absolutely 100% forbidden from playing with your cards. After a few minutes of interrogation Billy confesses that he indeed took a few consecutive cards from the middle of the stack, but he swears that he put them back in exactly the same order as they were. You suspect that Billy, being so young, may have simply mistakenly reversed the order of the cards that he took. Now you want to check your theory and decide if you can find the batch of cards that Billy took to play with. 

Is it possible to restore the order of the cards in to non-decreasing order of their rarity by reversing just one contiguous batch of cards?

The input consists of: 

• One line containing an integer n (1 ≤ n ≤ 10^6), the number of cards in your collection. 

• One line containing n integers v1,...,vn (1 ≤ vi ≤ 10^9 for all i), the current order of the cards’ rarity values.

If the cards can be sorted by reversing exactly one contiguous subsequence of the list, then output the 1-based start and end indices of such a subsequence. Otherwise, output “impossible”. If there are multiple valid solutions you may output any one of them.

本题答案不唯一,符合要求的答案均正确

样例输入1复制

7
10 13 19 19 15 14 20

样例输出1复制

3 6

样例输入2复制

6
9 1 8 2 7 3

样例输出2复制

impossible

样例输入3复制

3
1 2 3

样例输出3复制

2 2

题意:给你一串数字,要求你找到一串子序列,把这串子序列直接颠倒过来,可以将整串数字变成从小到大排列的序列。

思路:对于原序列a1,a2,...,an,构建一个与之完全相同的序列b1,b2,...,bn.并将b从小到大排序。

将序列a与序列b依次比较,left为从前往后比较第一个a[i]与b[i]不同的i,right为从后往前比较第一个a[i]与b[i]不同的i。

如果left,right都为0,说明原序列原本就是从小到大排列,输出"1 1".

如果left,right不为0,查找从下标left到right-1有没有a[i]<a[i+1]的数出现,如果出现说明不可能只颠倒一个子序列就可以将整个序列变成从小到大排列的序列 。如果没有这样的数出现,输出left,right。

#include <cstdio>
#include <iostream>
#include <algorithm>
#include <cstring>
#include <map>

using namespace std;

const int N=1e6+10;
typedef long long ll;

int a[N];
int b[N];

int main()
{
	int n;
	cin>>n;
	for(int i=1;i<=n;i++) 	
	{
		scanf("%d",&a[i]);
		b[i]=a[i];
	}
	sort(b+1,b+n+1);
	bool flag=0;
	int left=0,right=0;
	for(int i=1;i<=n;i++) 
		if(a[i]!=b[i])
		{
			left=i;
			break;
		 } 
	for(int i=n;i>=1;i--)
		if(a[i]!=b[i])
		{
			right=i;
			break;
		}
	for(int i=left;i<=right-1;i++) if(a[i]<a[i+1]) flag=1;
	if(!left&&!right) printf("1 1\n");
	else if(left&&right&&!flag) printf("%d %d\n",left,right);
	else if(left&&right&&flag) printf("impossible\n");

	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
资源包主要包含以下内容: ASP项目源码:每个资源包中都包含完整的ASP项目源码,这些源码采用了经典的ASP技术开发,结构清晰、注释详细,帮助用户轻松理解整个项目的逻辑和实现方式。通过这些源码,用户可以学习到ASP的基本语法、服务器端脚本编写方法、数据库操作、用户权限管理等关键技术。 数据库设计文件:为了方便用户更好地理解系统的后台逻辑,每个项目中都附带了完整的数据库设计文件。这些文件通常包括数据库结构图、数据表设计文档,以及示例数据SQL脚本。用户可以通过这些文件快速搭建项目所需的数据库环境,并了解各个数据表之间的关系和作用。 详细的开发文档:每个资源包都附有详细的开发文档,文档内容包括项目背景介绍、功能模块说明、系统流程图、用户界面设计以及关键代码解析等。这些文档为用户提供了深入的学习材料,使得即便是从零开始的开发者也能逐步掌握项目开发的全过程。 项目演示与使用指南:为帮助用户更好地理解和使用这些ASP项目,每个资源包中都包含项目的演示文件和使用指南。演示文件通常以视频或图文形式展示项目的主要功能和操作流程,使用指南则详细说明了如何配置开发环境、部署项目以及常见问题的解决方法。 毕业设计参考:对于正在准备毕业设计的学生来说,这些资源包是绝佳的参考材料。每个项目不仅功能完善、结构清晰,还符合常见的毕业设计要求和标准。通过这些项目,学生可以学习到如何从零开始构建一个完整的Web系统,并积累丰富的项目经验。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值