Oil Deposits

题目 :

Oil Deposits

 

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid. 

Input

The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket. 

Output

For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets. 

Sample Input

1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5 
****@
*@@*@
*@**@
@@@*@
@@**@
0 0 

Sample Output

0
1
2
2

题解:

首先看题意你应该知道,要找到有多少片油田,这里的多少片是指一个油田的如果相邻的8个方向上如果有油田,那么这两个油田就定义在一片油田里。

这应该算是深搜的经典题了。我的思路是这样的:首先,你肯定要以每一个油田为起点找出成片的油田。那就先遍历每一个油田,找出'@'(油田),这是一个,你还要看它是否和其他油田连在一起。于是,之前定义的ans+1(ans为油田的片数),把遍历到的其中一个油田的坐标放入dfs函数,标记为*,因为你已经ans+1了,记录过这个油田,就不用管它了。接着看从8个方向这个已经被标记为*的油田周围还有没有和它连成一片的油田,有的话再进入dfs标记它。

其实这个深度搜索的功能主要是先找到一个油田,然后深搜和它连成一片的油田,把那些油田全部标记,不影响搜索下一片的油田。

AC代码:

#include <iostream>
//#define LOCAL

using namespace std;

const int N = 105;

int row, col;  //定义行和列
char path[N][N];  //存图
int dir[8][2] = {{1, 0},{-1, 0},{0, 1},{0, -1}, {1, 1},{1, -1},{-1, -1},{-1, 1}}; 

void dfs(int x, int y)       
{
	path[x][y] = '*';
	
	for(int i = 0; i < 8; i ++ )
	{
		int x2 = x + dir[i][0];   //x2、y2为向八个方向中其中一个方向前进后的坐标
		int y2 = y + dir[i][1];
		
		if(x2 >= 0 && x2 < row && y2 >= 0 && y2 < col && path[x2][y2] == '@') dfs(x2, y2);
	}
	
	return;
}

int main()
{
//	#ifdef LOCAL
//	freopen("input.txt","r",stdin);
//	freopen("output.txt","w",stdout);
//	#endif

    while(cin >> row >> col && row)
    {	
    	int ans = 0;
        for(int i = 0; i < row; i ++ ) cin >> path[i];
        
        for(int i = 0; i < row; i ++ )
            for(int j = 0; j < col; j ++ )
            	if(path[i][j] == '@')
            	{
            		dfs(i, j);
            		ans ++;
				}
				
	    cout << ans << endl; 
    }
    
    return 0;
}

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值