Romantic

题目链接

The Sky is Sprite. 
The Birds is Fly in the Sky. 
The Wind is Wonderful. 
Blew Throw the Trees 
Trees are Shaking, Leaves are Falling. 
Lovers Walk passing, and so are You. 
................................Write in English class by yifenfei 

 

Girls are clever and bright. In HDU every girl like math. Every girl like to solve math problem! 
Now tell you two nonnegative integer a and b. Find the nonnegative integer X and integer Y to satisfy X*a + Y*b = 1. If no such answer print "sorry" instead. 

Input

The input contains multiple test cases. 
Each case two nonnegative integer a,b (0<a, b<=2^31) 

Output

output nonnegative integer X and integer Y, if there are more answers than the X smaller one will be choosed. If no answer put "sorry" instead. 

Sample Input

77 51
10 44
34 79

Sample Output

2 -3
sorry
7 -3

就是一个扩展欧几里得的简单题。

题意: 

给你两个非负整数a、b,让你确认这两个数是否满足 X*a + Y*b = 1(x是整数、y是整数),不满足输出"sorry",满足的话输出x、y,如果有多组数据满足的话,选择x较小的那一组。

题解:

解题思路:

用扩展欧几里得解题,需要满足a*x+b*y=gcd(a,b)。因此此题需要满足,gcd(a,b)=1,如果不满足的话输出"sorry",满足的话用扩展欧几里得求解x、y即可。题目中有一个限制条件,x为最小正数。如果直接求解出来x、y的话,x、y有无数个,肯定有x为负数的时候,于是,就到了用到扩展欧几里得公式的通解的时候了。

欧几里得公式的通解:

X=X0+b*t.

Y=Y0+a*t.(t为任意整数)

如果x<0的话,用个while循环,让它+若干倍的b成为整数就行了。

AC代码:

//#include <bits/stdc++.h>
#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>

using namespace std;

typedef long long ll;

ll exgcd(ll a,ll b,ll &x,ll &y)
{
	if(b==0)
	{
		x=1,y=0;
		return a;
	}
	ll r=exgcd(b,a%b,x,y);
	ll tmp=y;
	y=x-(a/b)*y;
	x=tmp;
	
	return r;
}

int main()
{
//	freopen("input.txt","r",stdin); 
    ll a,b;
    while(~scanf("%lld%lld",&a,&b))
    {
    	ll gcd=__gcd(a,b);
    	if(gcd!=1) printf("sorry\n");
    	else
    	{
    		ll x,y;
    		exgcd(a,b,x,y);
    		while(x<0)
    		{
    			x=x+b;
    			y=y-a;
			}
			printf("%lld %lld\n",x,y);
		}
	}
    
	return 0;
}

涉及知识点:

欧几里得公式的通解:

X=X0+b*t.

Y=Y0+a*t.(t为任意整数)

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值