Number Sequence

题目链接

Given two sequences of numbers : a[1], a[2], ...... , a[N], and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one. 

Input

The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a[N]. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000]. 

Output

For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead. 

Sample Input

2
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 1 3
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 2 1

Sample Output

6
-1

题解:

这是一道简单的kmp算法题,只要把kmp模板中的字符串换成int数组就行了。

这道题本来我做错了,我估计是中间过程由于复杂而出错了,看了同学的代码之后发现他的很简洁。

有三处可取之处:

1、如果是字符串的话,根据kmp算法应该在两个字符串之间+“#”的,那么如果是两个数组之间呢?他巧妙地在两个数组之间加上一个数字1e8,这个数字在两个数组之间是没有出现过的。

2、如果是字符串的话,是先输入再将两个字符串给+起来,当变成数组时,他将本来应该是两个数组的所有数字全部存到一个数组里面,这就大大简化了程序。

3、之前会长教的kmp是返回vector类型的,他将之转化成普通的数组类型,用起来也更加方便。

AC代码:

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>

using namespace std;

typedef long long ll;
const int maxn=1e6+1e4+10;

int lens,lent;
int a[maxn];
int nxt[maxn];

void cal_nxt()
{
	nxt[0]=0;
	for(int i=1;i<lent+lens+1;i++)
	{
		int j=nxt[i-1];
		while(a[i]!=a[j]&&j>0) j=nxt[j-1];
		if(a[i]==a[j]) j++;
		nxt[i]=j;
	}
}

int main()
{
//	freopen("input.txt","r",stdin); 
	std::ios::sync_with_stdio(false);
	
	int T;
	cin>>T;
	while(T--)
	{
		memset(a,0,sizeof a);
		memset(nxt,0,sizeof nxt);
		
		cin>>lens>>lent;
		a[lent]=1e8;
		for(int i=lent+1;i<lent+lens+1;i++)
		{
			cin>>a[i];
		}
		for(int i=0;i<lent;i++)
		{
			cin>>a[i];
		}
		cal_nxt();
		int flag=-1;
		for(int i=lent+1;i<lent+lens+1;i++)
		{
			if(nxt[i]==lent)
			{
				cout<<i-lent-lent+1<<endl;
				flag=1;
				break;
			}
		}
		if(flag<0) cout<<flag<<endl;
	}
	
		
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值