G - Lowest Bit

G - Lowest Bit

Given an positive integer A (1 <= A <= 100), output the lowest bit of A.

For example, given A = 26, we can write A in binary form as 11010, so the lowest bit of A is 10, so the output should be 2.

Another example goes like this: given A = 88, we can write A in binary form as 1011000, so the lowest bit of A is 1000, so the output should be 8.

Input

Each line of input contains only an integer A (1 <= A <= 100). A line containing “0” indicates the end of input, and this line is not a part of the input data.

Output

For each A in the input, output a line containing only its lowest bit.

Sample Input

26
88
0

Sample Output

2
8

代码块

代码块语法遵循标准markdown代码,例如:

#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<string.h>
#include<math.h>
using namespace std;
int a[32];
int main()
{
    int A,i,j;
    int shang,yushu,mark=31;
    while(cin>>A && A)
    {
        mark=31;
      for(i=0;i<32;i++)
       a[i]=0;
     shang=A/2;
     a[mark--]=A%2; //将数组倒着存放
     while(shang!=0)
     {
        a[mark--]=shang%2;
        shang=shang/2;
      } //转换成二进制数存入数组a
    //  for(i=mark;i<32;i++)
       // cout<<a[i]<<" ";
        j=0;
       for(i=31;i>=0;i--)//将数组逆置,查找第一次出现1的那个数,这样才能将二进制数转换成十进制数
       {
          if(a[i]==0)
           j++;//计算在1前面有多少个0
         if(a[i]==1)
        {
           j=pow(2,j);//讲二进制数转换成十进制数
           cout<<j<<endl;
            break;     
        }
       }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值