1070 Mooncake

原题

Mooncake is a Chinese bakery product traditionally eaten during the Mid-Autumn Festival. Many types of fillings and crusts can be found in traditional mooncakes according to the region's culture. Now given the inventory amounts and the prices of all kinds of the mooncakes, together with the maximum total demand of the market, you are supposed to tell the maximum profit that can be made.

Note: partial inventory storage can be taken. The sample shows the following situation: given three kinds of mooncakes with inventory amounts being 180, 150, and 100 thousand tons, and the prices being 7.5, 7.2, and 4.5 billion yuans. If the market demand can be at most 200 thousand tons, the best we can do is to sell 150 thousand tons of the second kind of mooncake, and 50 thousand tons of the third kind. Hence the total profit is 7.2 + 4.5/2 = 9.45 (billion yuans).

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers N (≤1000), the number of different kinds of mooncakes, and D (≤500 thousand tons), the maximum total demand of the market. Then the second line gives the positive inventory amounts (in thousand tons), and the third line gives the positive prices (in billion yuans) of N kinds of mooncakes. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the maximum profit (in billion yuans) in one line, accurate up to 2 decimal places.

Sample Input:

3 200
180 150 100
7.5 7.2 4.5

结尾无空行

Sample Output:

9.45

结尾无空行

思路

这道题思路是简单的,优先卖贵的月饼就好了。

通过代码

学习了一下柳神的格式,工工整整的看着好爽。

#include <bits/stdc++.h>
using namespace std;
typedef pair <double ,double> mooncake;
bool cpm(mooncake a,mooncake b){
    return a.second/a.first>b.second/b.first;//按价格由贵到便宜排序
}
int main(){
    double profit=0;
    int n,amount;
    scanf("%d%d",&n,&amount);
    vector <mooncake> cakes(n);
    for(int i=0;i<n;i++)scanf("%lf",&cakes[i].first);
    for(int i=0;i<n;i++)scanf("%lf",&cakes[i].second);
    sort(cakes.begin(),cakes.end(),cpm);
    for(int i=0;i<n;i++){
        if(cakes[i].first<amount){
            amount-=cakes[i].first;
            profit+=cakes[i].second;
        }else{
            profit+=cakes[i].second*amount/cakes[i].first;
            break;
        }
    }
    printf("%.2f",profit);
    return 0;
}

总结

知识

vector虽然说是可变数组,但是后面真的不接长度的话,是无法访问的,会报错提示越界。

vector <pair <double ,double> > cakes;
for(int i=0;i<n;i++){...}//会报错的

vector <pair <double ,double> > cakes (n);//n是已经读入的整数
for(int i=0;i<n;i++){...}//正确

技巧

  1. 注意下面这种写法是错误的
    pair < int, double > mooncake;
    vector <mooncake> cakes;//错误的
    这是定义了一个名叫mooncake的变量,不能在vector<>里面放一个变量名,只能放类型名,例如:
    typedef pair < int ,double > mooncake;
    vector <mooncake> cakes;
    如果要把复杂的数据类型用在迭代器里,也建议用上面这种方式,避免麻烦也方便修改。
  2. 对于下面这种常见的单句循环,建议用第一种方式代替第二种方式:

    for(int i=0;i<n;i++)scanf("%lf",&cakes[i].first);//1
    
    for(int i=0;i<n;i++){
        scanf("%lf",&cakes[i].first);
    }//2

    这样代码高度更短,更方便浏览。

心态 

  1. 首先我题就没看懂,因为我潜意识里默认price是每种月饼的单价( billion yuan/thousand ton),然后就不太懂为什么例子里先买7.2而不是7.5,然后还把两个单价相加???然后去搜了别人的博客才明白这里price是一种月饼的总价,(其实结合常识也能知道,如果是7.2billion yuan/thousand ton,算出来是7200元/kg,应该不太常见/doge),下次读题的时候拜托结合例子认真理解题意。
  2. 题目很坑人的一点是市场需求量用的是positive integers,给的例子里每种月饼数量也都为正整数,我自然地以为(别说了就是马虎)每种月饼的数量都是int类型,结果跑出来只有部分正确(23/25),改成double立刻全对。由此谨记,以后每次做题的时候看清楚每种数据的类型,写完后如果有问题就检查一下自己判断的数据类型是否有误。
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
import java.io.BufferedReader; import java.io.IOException; import java.io.InputStreamReader; import java.util.ArrayList; import java.util.Arrays; import java.util.Collection; import java.util.Collections; import java.util.LinkedList; import java.util.List; import java.util.Scanner; public class Main{ public static void main(String[] args) throws IOException { BufferedReader in=new BufferedReader(new InputStreamReader(System.in)); int n; double need; double sum=0; String s[]=in.readLine().split(" "); n=Integer.parseInt(s[0]); need=Double.parseDouble(s[1]); String amount[]=in.readLine().split(" "); String price[]=in.readLine().split(" "); ArrayList<Mooncake> cakes=new ArrayList<Mooncake>(); for(int i=0;i<n;i++){ Mooncake cake=new Mooncake(); cake.setAmount(Double.parseDouble(amount[i])); cake.setSales(Double.parseDouble(price[i])); cake.setValues(Double.parseDouble(price[i])/Double.parseDouble(amount[i])); cakes.add(cake); } Collections.sort(cakes); for(Mooncake c: cakes){ if(need>=c.amount){ need=need-c.amount; sum+=c.amount*c.values; } else{ sum+=need*c.values; need=0; } if(need==0){ break; } } System.out.printf("%.2f",sum); } static class Mooncake implements Comparable<Mooncake>{ double amount; double sales; double values; public double getAmount() { return amount; } public void setAmount(double amount) { this.amount = amount; } public double getSales() { return sales; } public void setSales(double sales) { this.sales = sales; } public double getValues() { return values; } public void setValues(double values) { this.values = values; } @Override public int compareTo(Mooncake arg0) { // TODO Auto-generated method stub return this.values>arg0.values?-1:1; } } }转c++
05-23

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值