hdu 6182A Math Problem(快速幂)

You are given a positive integer n, please count how many positive integers k satisfy  kknkk≤n. 

InputThere are no more than 50 test cases. 

Each case only contains a positivse integer n in a line. 

1n10^18
OutputFor each test case, output an integer indicates the number of positive integers k satisfy k^k ≤ n in a line.

Sample Input

1
4

Sample Output

1
2
主要注意long最大为多少 2^63-1,先求出来,就知道15^15正好小于,16^16就超long的范围

代码:
import java.math.BigInteger;
import java.util.Scanner;

public class Main{
        static long quick_pow(long a, long b){
                long res = 1;
                while(b > 0){
                        if((b&1) == 1) res = res * a;
                        a = a * a;
                        b >>= 1;
                }
                return res;
        }
        public static void main(String[] args) {
                Scanner scan=new Scanner(System.in);
//                BigInteger a=new BigInteger("2");
//                System.out.println(a.pow(64));
//                for(int i=1;i<=20;i++)
//                    System.out.println(quick_pow(i,i));
                while(scan.hasNext()){
                        int cnt=15;
                        long n=scan.nextLong();
                        for(long i=15;i>=1;i--){
                                if(quick_pow(i,i)>n) cnt--;
                                else break;
                        }
                        System.out.println(cnt);
                }
        }
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值