E - Birthday Paradox LightOJ - 1104(生日悖论)

Sometimes some mathematical results are hard to believe. One of the common problems is the birthday paradox. Suppose you are in a party where there are 23 people including you. What is the probability that at least two people in the party have same birthday? Surprisingly the result is more than 0.5. Now here you have to do the opposite. You have given the number of days in a year. Remember that you can be in a different planet, for example, in Mars, a year is 669 days long. You have to find the minimum number of people you have to invite in a party such that the probability of at least two people in the party have same birthday is at least 0.5.

Input
Input starts with an integer T (≤ 20000), denoting the number of test cases.

Each case contains an integer n (1 ≤ n ≤ 105) in a single line, denoting the number of days in a year in the planet.

Output
For each case, print the case number and the desired result.

Sample Input
2

365

669

Sample Output
Case 1: 22

Case 2: 30

题目大意:输入一个天数,找到最小的人数,使人群中至少有两个人同一天生日的概率至少是0.5。

思路:其实这是一个生日悖论的裸题,我们可以先拿365天做例子。但是我们要算的是每个人生日不同的概率。式子如下;
在这里插入图片描述
n为至少的人数,而P就是至少两个人生日相同的概率。可以解释一下,第一个人在365天中随便选一天,而第二个人在365天只能选364天,以此类推得到此式。虽然这个式子简单,易于理解,但求阶乘会导致时间复杂度很高,而且还会爆long long,所以这个方法适合理解,不适合用来做题。
这里会给出一个近似解法,可以大大减少复杂度,式子如下:在这里插入图片描述
给了式子就可以暴力了,暴力出奇迹。

上代码

#pragma GCC optimize(2)
#include<bits/stdc++.h> 
using namespace std;
typedef long long ll;
const int maxn=1e5+7;
const int mod=1e9+7;
const double eps=1e-6;
double cnt,sum,ans;
int main()
{
	ll t;
	cin>>t;
	for(ll k=1;k<=t;k++)
	{
		double n;
		cin>>n;
		ans=1.0;
		cnt=1.0;
		while(ans>0.5000)
		{
			ans*=(1-cnt/n);
			cnt++;
		}
		printf("Case %lld: ",k);
		cout<<cnt-1<<endl;
	}
	return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值