PAT刷题之旅 1121-Damn Single-甲级

题目
“Damn Single (单身狗)” is the Chinese nickname for someone who is being single. You are supposed to find those who are alone in a big party, so they can be taken care of.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=50000), the total number of couples. Then N lines of the couples follow, each gives a couple of ID’s which are 5-digit numbers (i.e. from 00000 to 99999). After the list of couples, there is a positive integer M (<=10000) followed by M ID’s of the party guests. The numbers are separated by spaces. It is guaranteed that nobody is having bigamous marriage (重婚) or dangling with more than one companion.

Output Specification:

First print in a line the total number of lonely guests. Then in the next line, print their ID’s in increasing order. The numbers must be separated by exactly 1 space, and there must be no extra space at the end of the line.

Sample Input:

3
11111 22222
33333 44444
55555 66666
7
55555 44444 10000 88888 22222 11111 23333
Sample Output:

5
10000 23333 44444 55555 88888

题目大意
先给出情侣两两配对的情况,之后再给出一些人要求判断谁是单生狗。

解题思路
用数组或结构体数组标记一对情侣即可。

#include<iostream>
#include<algorithm>
#include<cstring>
#include<string>
using namespace std;
struct node{
    int cnt;
}ans[100005];
int main()
{
    int n,m;
    int p,q;
    int b[100005];
    int v[100005];
    int c[100005];
    memset(v,0,sizeof(v));
    cin>>n;
    for(int i=0;i<n;i++)
    {
        cin>>p;
        cin>>q;
        v[p]=1;
        v[q]=1;
        ans[p].cnt=i;
        ans[q].cnt=i;
    }
    cin>>m;
    for(int i=0;i<m;i++)
    {
        cin>>b[i];
    }
    sort(b,b+m);
    int k=0,t;
    for(int i=0;i<m;i++)
    {
        t=0;
        for(int j=0;j<m;j++)
        {
            if(i==j)
                continue;
            if(v[b[i]]==1&&v[b[j]]==1&&ans[b[i]].cnt==ans[b[j]].cnt)
            {
                t=1;
                break;
            }
        }
        if(t==0)
        {
            c[k++]=b[i];
        }
    }
    cout<<k<<endl;
    for(int i=0;i<k;i++)
    {
        if(i!=0)
            cout<<" ";
        printf("%05d",c[i]);
    }
    return 0;
}

心得
这题虽简单,但细节比较多。测试不过,可能为没有注意到不够五位的情况,也可能是没注意到自己和自己不能比较的情况。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值