PAT A 7-2 1121 Damn Single (25分)

1121 Damn Single (25分)
“Damn Single (单身狗)” is the Chinese nickname for someone who is being single. You are supposed to find those who are alone in a big party, so they can be taken care of.

Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (≤ 50,000), the total number of couples. Then N lines of the couples follow, each gives a couple of ID’s which are 5-digit numbers (i.e. from 00000 to 99999). After the list of couples, there is a positive integer M (≤ 10,000) followed by M ID’s of the party guests. The numbers are separated by spaces. It is guaranteed that nobody is having bigamous marriage (重婚) or dangling with more than one companion.

Output Specification:
First print in a line the total number of lonely guests. Then in the next line, print their ID’s in increasing order. The numbers must be separated by exactly 1 space, and there must be no extra space at the end of the line.

Sample Input:

3
11111 22222
33333 44444
55555 66666
7
55555 44444 10000 88888 22222 11111 23333

Sample Output:

5
10000 23333 44444 55555 88888

坑点:

  • 00000 (第二个测试点)

  • 输出位数不足5位 (第五个测试点)

  • 运行超时问题

#include<bits/stdc++.h>
using namespace std;
unordered_map<int,int> mp;
unordered_map<int,int> mi;
set<int> st;
int n,k;
int va1,va2,peo;
int main(){
	scanf("%d",&n);
	for(int i=0;i<n;i++){
		scanf("%d %d",&va1,&va2);
		mp[va1]=va2;
		mp[va2]=va1;
	}
	scanf("%d",&k);
	for(int i=0;i<k;i++){
		scanf("%d",&peo);
		if(mp[peo]==0 && mp[0]!=peo){
			st.insert(peo);
		}else{
			if(	mi[mp[peo]]==0) mi[peo]=1;
			else mi[mp[peo]]=0;
		}  
	}
    for(auto it=mi.begin();it!=mi.end();it++){
		if(it->second==1)st.insert(it->first);
	}	
	printf("%d\n",st.size());
	for(auto it=st.begin();it!=st.end();it++){
		if(it==st.begin())cout<<setw(5)<<setfill('0')<<*it;
		else cout<<" "<<setw(5)<<setfill('0')<<*it;
	}
	return 0;
}

在这里插入图片描述

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

隔壁de小刘

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值