1038 统计同成绩学生(C++)

题目详情
本题要求读入 N 名学生的成绩,将获得某一给定分数的学生人数输出。

输入格式:

输入在第 1 行给出不超过 10​5​​ 的正整数 N,即学生总人数。随后一行给出 N 名学生的百分制整数成绩,中间以空格分隔。最后一行给出要查询的分数个数 K(不超过 N 的正整数),随后是 K 个分数,中间以空格分隔。

输出格式:

在一行中按查询顺序给出得分等于指定分数的学生人数,中间以空格分隔,但行末不得有多余空格。

输入样例:

10
60 75 90 55 75 99 82 90 75 50
3 75 90 88

输出样例:

3 2 0

 



-第一次的超时代码 ,代码如下

#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <cmath>
#include <stdlib.h>
#include <algorithm>
using namespace std;

int a[101];

int main()
{
	int n, temp;
	cin>>n;
	for(int i=0;i<n;i++)
	{
		cin>>temp;
		a[temp]++;
	}
	
	cin>>n;
	cin>>temp;
	cout<<a[temp];
	for(int i=1;i<n;i++)
	{
		cin>>temp;
		cout<<" "<<a[temp];
	}
	
	return 0;
}


-第二次改了输入和输出的代码就可以过,代码如下
 

#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <cmath>
#include <stdlib.h>
#include <algorithm>
using namespace std;

int a[101];

int main()
{
	int n, temp;
	cin>>n;
	for(int i=0;i<n;i++)
	{
		cin>>temp;
		a[temp]++;
	}
	
	scanf("%d",&n);
	scanf("%d",&temp);
	printf("%d",a[temp]);
	for(int i=1;i<n;i++)
	{
		scanf("%d",&temp);
		printf(" %d",a[temp]);
	}
	
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

重剑DS

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值