hdu 1285确定比赛名次(C++)---拓扑排序(优先队列+链式前向星数据结构)

 

题目链接

 

确定比赛名次

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 54699    Accepted Submission(s): 20227


 

Problem Description
有N个比赛队(1<=N<=500),编号依次为1,2,3,。。。。,N进行比赛,比赛结束后,裁判委员会要将所有参赛队伍从前往后依次排名,但现在裁判委员会不能直接获得每个队的比赛成绩,只知道每场比赛的结果,即P1赢P2,用P1,P2表示,排名时P1在P2之前。现在请你编程序确定排名。
 

 

Input
输入有若干组,每组中的第一行为二个数N(1<=N<=500),M;其中N表示队伍的个数,M表示接着有M行的输入数据。接下来的M行数据中,每行也有两个整数P1,P2表示即P1队赢了P2队。
 

 

Output
给出一个符合要求的排名。输出时队伍号之间有空格,最后一名后面没有空格。

其他说明:符合条件的排名可能不是唯一的,此时要求输出时编号小的队伍在前;输入数据保证是正确的,即输入数据确保一定能有一个符合要求的排名。
 

 

Sample Input
 
4 3 1 2 2 3 4 3
 

 

Sample Output
 
1 2 4 3
 

 

 


 

 

AC代码如下

#include <iostream>
#include <cstring>
#include <queue>
#include <vector>
#include <functional> //因为用了greater<int>()
using namespace std;
const int maxn = 510, maxm = 124751;
struct edge { //链式前向星 
	int to, next;
}e[maxm];
int head[maxn], inDegree[maxn], ans[maxn];
int cnt, n, m, t;
inline void add_edge(int u, int v) {
	cnt++; //cnt为每条边的编号 
	e[cnt].to = v;
	e[cnt].next = head[u];
	head[u] = cnt;
	
	inDegree[v]++;
}
 
int main()
{
	while (cin >> n >> m) {
		cnt = 0;
		memset(head, 0, sizeof(head));
		memset(inDegree, 0, sizeof(inDegree));
		int t1, t2;
		for(int i = 1; i <= m; i++) {
			cin >> t1 >> t2;
			add_edge(t1, t2);
		}
		t = 1;
		
		/*开始使用优先队列进行拓扑排序*/
		priority_queue<int, vector<int>, greater<int> > que; //使用小顶堆(父节点总是小于或等于子节点)
		for(int i = 1; i <= n; i++) {
			if (inDegree[i] == 0) que.push(i); //找入度为0的结点,并让其加入队列
		}
		
		while (!que.empty()) {
			int temp = que.top();
			que.pop();
			ans[t++] = temp;
			for(int i = head[temp]; i; i = e[i].next) { //找与该节点相连接的点
				 inDegree[e[i].to]--; //该节点相连接的点的入度-1
				 if (inDegree[e[i].to]==0) que.push(e[i].to);
			}
		}
		
		cout << ans[1];
		for(int i = 2; i <= n; i++) cout << " " << ans[i];
		cout << endl;
	}
	
	return 0;
}

 

  • 1
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

重剑DS

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值