Sudoku POJ - 2676 题解

原题

Sudoku is a very simple task. A square table with 9 rows and 9 columns is divided to 9 smaller squares 3x3 as shown on the Figure. In some of the cells are written decimal digits from 1 to 9. The other cells are empty. The goal is to fill the empty cells with decimal digits from 1 to 9, one digit per cell, in such way that in each row, in each column and in each marked 3x3 subsquare, all the digits from 1 to 9 to appear. Write a program to solve a given Sudoku-task.
在这里插入图片描述

Input
The input data will start with the number of the test cases. For each test case, 9 lines follow, corresponding to the rows of the table. On each line a string of exactly 9 decimal digits is given, corresponding to the cells in this line. If a cell is empty it is represented by 0.
Output
For each test case your program should print the solution in the same format as the input data. The empty cells have to be filled according to the rules. If solutions is not unique, then the program may print any one of them.

Sample Input
1
103000509
002109400
000704000
300502006
060000050
700803004
000401000
009205800
804000107
Sample Output
143628579
572139468
986754231
391542786
468917352
725863914
237481695
619275843
854396127

代码

#include <cstdio>
using namespace std;
int a[10][10]; //用来存放数独表格
char s[10][10]; //读入的时候按行读入
int flag; //标记是否填完表格

bool ok(int k,int x,int y){
    for(int i=0;i<9;i++) //遍历 x,y所在的行和列,看看该数是否与同行或同列的数字重复
        if(a[i][y]==k||a[x][i]==k) //重复的话则行不通
            return false;
    int u=x/3*3,v=y/3*3; //接下来对九宫格进行判重
    for(int i=0;i<3;i++)
        for(int j=0;j<3;j++)
            if(a[i+u][j+v]==k)
                return false;
    return true;
}

void dfs(int x,int y){
    if(flag||x==9){ //如果已经填完表格或者x到达最大行+1,结束填表
        flag=true;
        return;
    }
    while(a[x][y]){ //找到当前行为 0 的格子
        if(y==8) //如果列达到最大值,则移到下一行开始遍历
            x++,y=0;
        else
            y++; //否则探索当前行的下一列
        if(x==9){ //由于前面可能因为 y达到最大值而使得 x为 9,所以这里需要特殊判断
            flag=true;
            return;
        }
    }
    for(int k=1;k<=9;k++){ //找到空格后开始填数字
        if(ok(k,x,y)){ //如果当前数字可行
            a[x][y]=k; //填
            if(y==8) //如果达到最大列,遍历下一行
                dfs(x+1,0);
            else
                dfs(x,y+1); //否则遍历下一列
            if(flag)
                return;
            a[x][y]=0;
        }
    }
}

int main(){
    int t;
    scanf("%d",&t);
    while(t--){
        for(int i=0;i<9;i++){
            scanf("%s",s[i]);
            for(int j=0;j<9;j++)
                a[i][j]=s[i][j]-'0';
        }
        flag=false;
        dfs(0,0);
        for(int i=0;i<9;i++){
            for(int j=0;j<9;j++)
                printf("%d",a[i][j]);
            printf("\n");
        }
    }
    return 0;
}
  • 4
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值