H - Tickets(动态规划)

题目
Jesus, what a great movie! Thousands of people are rushing to the cinema. However, this is really a tuff time for Joe who sells the film tickets. He is wandering when could he go back home as early as possible.
A good approach, reducing the total time of tickets selling, is let adjacent people buy tickets together. As the restriction of the Ticket Seller Machine, Joe can sell a single ticket or two adjacent tickets at a time.
Since you are the great JESUS, you know exactly how much time needed for every person to buy a single ticket or two tickets for him/her. Could you so kind to tell poor Joe at what time could he go back home as early as possible? If so, I guess Joe would full of appreciation for your help.

输入
There are N(1<=N<=10) different scenarios, each scenario consists of 3 lines:

  1. An integer K(1<=K<=2000) representing the total number of people;
  2. K integer numbers(0s<=Si<=25s) representing the time consumed to buy a ticket for each person;
  3. (K-1) integer numbers(0s<=Di<=50s) representing the time needed for two adjacent people to buy two tickets together.

输出
For every scenario, please tell Joe at what time could he go back home as early as possible. Every day Joe started his work at 08:00:00 am. The format of time is HH:MM:SS am|pm.

样例输入

2
2
20 25
40
1
8

样例输出

08:00:40 am
08:00:08 am

题意
Joe是一个卖电影票的家伙,他想早点卖完票,这样就可以回家看《银魂》了 (●’◡’●)
现在有n个要买票的家伙,每个人买票需要一定时间买票。
当然,也可以让两个人一起买票来减少时间。

输入首先给出数字N代表样例数。
每个样例会先输入数字一个整数K代表买票的人数(1<=K<=2000);
然后第二行会给出K个数字,代表每个人买票所用的时间(0<=S<=25s)(s:秒);
第三行(可能没有)会给出K-1个数字,代表相邻两个人一起买票所耗的时间(0s<=Di<=50s)。

Joe从08:00:00 am开始卖票,请输出最早下班的时间。

思路
动态规划题,对于这种热爱银魂的家伙我们一定要好好帮助他(●’◡’●)

首先我们需要建立一个数组dp,dp[i]的意义为:前i个人所用掉的最少时间
t1数组中存储每个人的用时,t2数组中我们从第2个开始录入,t2[i]的意义为:第i个人和第i-1个人一起买票的时间

int t1[2005],t2[2005];
int dp[2005];

对于i=1时,那最少时间肯定就是t1[1]。
对于i=2时,我们要考虑是让2号自己买还是和1号(i-1)一起买:

2号自己买:dp[i-1]+t1[i] ;
2和1一起:dp[i-2]+t2[i],取两者之间最小值。

推广:dp[i]=min(dp[i-1]+t1[i],dp[i-2]+t2[i]);

放代码,「伊丽莎白」!

在这里插入图片描述
代码

#include<bits/stdc++.h>
using namespace std;
int t1[2005],t2[2005];
int dp[2005];
int t,n,m;
int main()
{
    cin>>t;
    while(t--)
    {
        cin>>n;
        for(int i=1; i<=n; i++)
            cin>>t1[i];
        for(int i=2; i<=n; i++)
            cin>>t2[i];
        memset(dp,0,sizeof(dp));
        dp[1]=t1[1];
        for(int i=2; i<=n; i++)
            dp[i]=min(dp[i-1]+t1[i],dp[i-2]+t2[i]);
        int h = dp[n]/3600;
        int m = dp[n]%3600/60;
        int s = dp[n]%60;
        printf("%02d:%02d:%02d %s\n",(8+h)%24,m,s,(8+h)%24>12?"pm":"am");   //dp[n]存的是秒,转换时间和输出
    }
}

想这里的标题就跟想短信标题一样麻烦~

在这里插入图片描述
开个会员只是为了我伊丽莎白大人!╰( ̄ω ̄o)

下次再见~
在这里插入图片描述

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值