C - Monkey and Banana(动态规划)

题目
A group of researchers are designing an experiment to test the IQ of a monkey. They will hang a banana at the roof of a building, and at the mean time, provide the monkey with some blocks. If the monkey is clever enough, it shall be able to reach the banana by placing one block on the top another to build a tower and climb up to get its favorite food.

The researchers have n types of blocks, and an unlimited supply of blocks of each type. Each type-i block was a rectangular solid with linear dimensions (xi, yi, zi). A block could be reoriented so that any two of its three dimensions determined the dimensions of the base and the other dimension was the height.

They want to make sure that the tallest tower possible by stacking blocks can reach the roof. The problem is that, in building a tower, one block could only be placed on top of another block as long as the two base dimensions of the upper block were both strictly smaller than the corresponding base dimensions of the lower block because there has to be some space for the monkey to step on. This meant, for example, that blocks oriented to have equal-sized bases couldn’t be stacked.

Your job is to write a program that determines the height of the tallest tower the monkey can build with a given set of blocks.

输入
The input file will contain one or more test cases. The first line of each test case contains an integer n,
representing the number of different blocks in the following data set. The maximum value for n is 30.
Each of the next n lines contains three integers representing the values xi, yi and zi.
Input is terminated by a value of zero (0) for n.

输出
For each test case, print one line containing the case number (they are numbered sequentially starting from 1) and the height of the tallest possible tower in the format “Case case: maximum height = height”.

样例输入

1
10 20 30
2
6 8 10
5 5 5
7
1 1 1
2 2 2
3 3 3
4 4 4
5 5 5
6 6 6
7 7 7
5
31 41 59
26 53 58
97 93 23
84 62 64
33 83 27
0

样例输出

Case 1: maximum height = 40
Case 2: maximum height = 21
Case 3: maximum height = 28
Case 4: maximum height = 342

题意
一组研究人员正在设计一项实验,以测试猴子的智商。他们将挂香蕉在建筑物的屋顶,同时,提供一些砖块给这些猴子。如果猴子足够聪明,它应当能够通过合理的放置一些砖块建立一个塔,并爬上去吃他们最喜欢的香蕉。

研究人员有n种类型的砖块,每种类型的砖块都有无限个。第i块砖块的长宽高分别用xi,yi,zi来表示。 同时,由于砖块是可以旋转的,每个砖块的3条边可以组成6种不同的长宽高。

在构建塔时,当且仅当A砖块的长和宽都分别小于B砖块的长和宽时,A砖块才能放到B砖块的上面,因为必须留有一些空间让猴子来踩。

你的任务是编写一个程序,计算猴子们最高可以堆出的砖块们的高度。

思路
输入虽然是n种砖块,每个砖块都可以通过旋转变成另一种砖块,假设砖块长宽高分别为x,y,z,那我们可以通过旋转获得以下砖块:

长  宽  高
x   y   z
x   z   y
y   x   z
y   z   x
z   x   y
z   y   x

所以一共是6*n种砖块。

对于所有类型砖块我们进行排序,按照长宽从大到小排列:

struct node
{
    int x,y,z;
} a[205];

bool cmp(node n,node m)   
{
    if(n.x==m.x)
        return n.y>m.y;
    return n.x>m.x;
}

然后我们设置一个dp数组,dp[i]的值代表使用第i个砖块能够达到的最大高度。
接下来就好办多了,我们直接看代码。

伊丽莎白!

在这里插入图片描述
代码

#include<bits/stdc++.h>
using namespace std;
struct node
{
    int x,y,z;
} a[205];
int x,y,z;
int dp[205];
bool cmp(node n,node m)   
{
    if(n.x==m.x)
        return n.y>m.y;
    return n.x>m.x;
}
int main()
{
    int k=1,n;
    while(~scanf("%d",&n)&&n)
    {
        int cnt=0,ans=-1;
        for(int i=0; i<n; i++)
        {
            scanf("%d%d%d",&x,&y,&z);
            a[cnt].x=x;
            a[cnt].y=y;
            a[cnt++].z=z;

            a[cnt].x=x;
            a[cnt].y=z;
            a[cnt++].z=y;

            a[cnt].x=z;
            a[cnt].y=x;
            a[cnt++].z=y;

            a[cnt].x=z;
            a[cnt].y=y;
            a[cnt++].z=x;

            a[cnt].x=y;
            a[cnt].y=x;
            a[cnt++].z=z;

            a[cnt].x=y;
            a[cnt].y=z;
            a[cnt++].z=x;
        }
        sort(a,a+cnt,cmp);
        for(int i=0;i<cnt;i++)
        {
            dp[i]=a[i].z;                  //对于第i个砖块,dp[i]初始值就是它本身的高度
            for(int j=0;j<i;j++)
            {
                if(a[i].x<a[j].x&&a[i].y<a[j].y)  //如果能把i放到j上需要满足的条件
                    dp[i]=max(dp[i],dp[j]+a[i].z);  
                ans=max(dp[i],ans);
            }
        }
        printf("Case %d: maximum height = %d\n",k++,ans); //输出格式注意
    }
}

下次再见~~

在这里插入图片描述

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值