【poj3061】Subsequence(尺取法)

43 篇文章 5 订阅
3 篇文章 0 订阅

Subsequence
Description
A sequence of N positive integers (10 < N < 100 000), each of them less than or equal 10000, and a positive integer S (S < 100 000 000) are given. Write a program to find the minimal length of the subsequence of consecutive elements of the sequence, the sum of which is greater than or equal to S.
Input
The first line is the number of test cases. For each test case the program has to read the numbers N and S, separated by an interval, from the first line. The numbers of the sequence are given in the second line of the test case, separated by intervals. The input will finish with the end of file.
Output
For each the case the program has to print the result on separate line of the output file.if no answer, print 0.
Sample Input

2
10 15
5 1 3 5 10 7 4 9 2 8
5 11
1 2 3 4 5

Sample Output

2
3

题目给定一串数列,求最短的连续数列和大于s,求这个序列的长度。

我们设以s开始总和最初大于S时的连续子序列为as+…+at1,这时
as+1+…+at2<as+…+at2<S
所以从as+1开始总和最初超过S的连续子序列如果是as+1+…+at’1的话,则必然有t≤t’。利用这一性
质便可以设计出如下算法:
(1) 以 s = t = sum = 0 初始化。
(2) 只要依然有 sum<S,就不断将 sum 增加 at,并将 t 增加 1。
(3) 如果(2)中无法满足 sum≥S 则终止。否则的话,更新 res = min(res, ts)。
(4) 将 sum 减去 as,s 增加 1 然后回到(2)。
对于这个算法,因为t最多变化n次,因此只需O(n)的复杂度就可以求解这个问题了。

#include<cstdio>
#include<algorithm>
using namespace std;
int a[100005];
int main()
{
    int i,j,x,T,s,n;
    scanf("%d",&T);
    while(T--){
    	scanf("%d %d",&n,&s);
    	for(i=0;i<n;i++){
    		scanf("%d",&a[i]);
		}
		int ans=n+1;
		int l=0,r=0,sum=0;
		while(1){
			while(r<n&&sum<s){
				sum+=a[r++];
			}
			if(sum<s) break;
			ans=min(ans,r-l);
			sum-=a[l++];
		}
		if(ans>n){
			ans=0;
		}
		printf("%d\n",ans);
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值